Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

I found the RDO documentation to be very helpful when I was going through the OVS setup. The OpenStack documentation did not have the configuration options that were included in the network scripts setup by RDO:

http://openstack.redhat.com/Neutron_with_existing_external_network

I had luck configuring the interfaces this way then using the ovs-vsctl add-port option:

Make /etc/sysconfig/network-scripts/ifcfg-br-ex resemble: (note this file shouldn't exist, but does due to a bug)

DEVICE=br-ex DEVICETYPE=ovs TYPE=OVSBridge BOOTPROTO=static IPADDR=192.168.122.212 # Old eth0 IP since we want the network restart to not kill the connection, otherwise pick something outside your dhcp range NETMASK=255.255.255.0 # your netmask GATEWAY=192.168.122.1 # your gateway DNS1=192.168.122.1 # your nameserver ONBOOT=yes

Make /etc/sysconfig/network-scripts/ifcfg-eth0 resemble (no BOOTPROTO!):

DEVICE=eth0 HWADDR=52:54:00:92:05:AE # your hwaddr TYPE=OVSPort DEVICETYPE=ovs OVS_BRIDGE=br-ex ONBOOT=yes

If you only have one interface and need to make sure that you do not drop your connection you could look at adding sub interfaces then working off of those with the br-ex:

eth0:0

I found the RDO documentation to be very helpful when I was going through the OVS setup. The OpenStack documentation did not have the configuration options that were included in the network scripts setup by RDO:

http://openstack.redhat.com/Neutron_with_existing_external_network

I had luck configuring the interfaces this way then using the ovs-vsctl add-port option:

Make /etc/sysconfig/network-scripts/ifcfg-br-ex resemble: (note this file shouldn't exist, but does due to a bug)

DEVICE=br-ex
DEVICETYPE=ovs
TYPE=OVSBridge
BOOTPROTO=static
IPADDR=192.168.122.212 # Old eth0 IP since we want the network restart to not kill the connection, otherwise pick something outside your dhcp range
NETMASK=255.255.255.0  # your netmask
GATEWAY=192.168.122.1  # your gateway
DNS1=192.168.122.1     # your nameserver
ONBOOT=yes

ONBOOT=yes

Make /etc/sysconfig/network-scripts/ifcfg-eth0 resemble (no BOOTPROTO!):

DEVICE=eth0
HWADDR=52:54:00:92:05:AE # your hwaddr
TYPE=OVSPort
DEVICETYPE=ovs
OVS_BRIDGE=br-ex
ONBOOT=yes

ONBOOT=yes

If you only have one interface and need to make sure that you do not drop your connection you could look at adding sub interfaces then working off of those with the br-ex:

eth0:0

 eth0:0