Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

aha!

The machine was using ufw. This is by default operating on br-ex as well as eth0 (firewall between the two).

aha!

The machine was using ufw. This is by default operating on br-ex as well as eth0 (firewall between the two).

ufw interferes with neutron and cannot be used (by default it applies rules to all interfaces). So disable it and place manual iptables rules in for firewalling the host.

The other answer given here is overly complex and not correct... you do not need two interfaces. I have one (eth0) which is the public IP of the 'all-in-one'. I created a single public network in neutron, did NOT bridge this to the eth0, allowing routing to take affect, and placed a NAT rule in place for packets exiting eth0. this works just fine.