Revision history [back]

  1. I belive your OVS bridge br-ex is not configured properly. It's supposed to have eth0 as OVS port. ( not eth2). Ifconfig report shoud show br-ex with IP 172.16.1.211 and eth0 with no IP at all

  2. I also belive that virtual public network has been built with mistake cidr - 172.16.0.0/16 shoud be 172.16.1.0/16 and --gateway 172.16.1.XX ( IP of your real gateway on this subnet ).

If you are getting my point you may work on your own, if not then ,please submit to me all what was requested above. I will try to have this job done for you. I think so because you are able to ping floating IP of your VM within qrouter namespace, what means that Neutron L2,L3 routing are in good shape. The problem seems to be in OVS configuration, which should be fixed first to proceed.

  1. 1. I belive your OVS bridge br-ex is not configured properly. It's supposed to have eth0 as OVS port. ( not eth2). Ifconfig report shoud show br-ex with IP 172.16.1.211 and eth0 with no IP at all

  2. all
  3. 2. I also belive that virtual public network has been built with mistake cidr - 172.16.0.0/16 shoud be 172.16.1.0/16 and --gateway 172.16.1.XX ( IP of your real gateway on this subnet ).

  4. ).

If you are getting my point you may work on your own, if not then ,please submit to me all what was requested above. I will try to have this job done for you. I think so because you are able to ping floating IP of your VM within qrouter namespace, what means that Neutron L2,L3 routing are in good shape. The problem seems to be in OVS configuration, which should be fixed first to proceed.

proceed.