Ask Your Question

Revision history [back]

To fix this error open PostgreSQL client authentication configuration file /var/lib/pgsql/data/pg_hba.conf:

# vi /var/lib/pgsql/data/pg_hba.conf

This file controls:

  • Which hosts are allowed to connect
  • How clients are authenticated
  • Which PostgreSQL user names they can use
  • Which databases they can access

By default Postgresql uses IDENT-based authentication. All you have to do is allow username and password based authentication for your network or webserver. IDENT will never allow you to login via -U and -W options. Append following to allow login via localhost only:

local   all all trust
host    all 127.0.0.1/32    trust

Save and close the file. Restart Postgresql server:

# service postgresql restart

By default Postgresql uses IDENT-based authentication. To fix this error open PostgreSQL client authentication configuration file /var/lib/pgsql/data/pg_hba.conf:

# vi /var/lib/pgsql/data/pg_hba.conf/var/lib/pgsql/data/pg_hba.conf

This file controls:

  • Which hosts are allowed to connect
  • How clients are authenticated
  • Which PostgreSQL user names they can use
  • Which databases they can access

By default Postgresql uses IDENT-based authentication. All you have to do is To allow username and password based authentication for your network or webserver. IDENT will never allow you to login via -U and -W options. Append append following to allow login via localhost only:only (modify the host if your keystone server is remote to the database server):

local   all all trust
host    all 127.0.0.1/32    trust

Save and close the file. Restart Postgresql server:Force the server to reload the configuration file using pg_ctl:

# service postgresql restartpg_ctl reload

By default Postgresql uses IDENT-based authentication. To fix this error open PostgreSQL client authentication configuration file /var/lib/pgsql/data/pg_hba.conf:

# vi /var/lib/pgsql/data/pg_hba.conf

To allow username and password based authentication append the following to allow login via localhost only (modify the host if your keystone server is remote to the database server):

local   all all trust
host    all 127.0.0.1/32    trust

Save and close the file. Force the server to reload the configuration file using pg_ctl:

# pg_ctl reload