Revision history [back]

click to hide/show revision 1
initial version

9lives, thanks for the response. I found the error, it appears DJANGO is just as picky about indentation as PYTHON is. If found and unexcited indentation error in /etc/openstack-dashboard/local_settings

root@controller ~]# tail -n 20 -f /var/log/httpd/error_log [Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10] File "/usr/lib/python2.6/site-packages/django/utils/functional.py", line 184, in inner [Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10] self._setup() [Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10] File "/usr/lib/python2.6/site-packages/django/conf/__init__.py", line 42, in _setup [Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10] self._wrapped = Settings(settings_module) [Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10] File "/usr/lib/python2.6/site-packages/django/conf/__init__.py", line 93, in __init__ [Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10] mod = importlib.import_module(self.SETTINGS_MODULE) [Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10] File "/usr/lib/python2.6/site-packages/django/utils/importlib.py", line 35, in import_module [Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10] __import__(name) [Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10] File "/usr/share/openstack-dashboard/openstack_dashboard/wsgi/../../openstack_dashboard/settings.py", line 222, in <module> [Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10] from local.local_settings import * # noqa [Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10] File "/usr/share/openstack-dashboard/openstack_dashboard/wsgi/../../openstack_dashboard/local/local_settings.py", line 111 [Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10] CACHES = { [Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10] ^ [Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10] IndentationError: unexpected indent [Thu Apr 24 08:12:30 2014] [notice] caught SIGTERM, shutting down [Thu Apr 24 08:12:31 2014] [notice] SELinux policy enabled; httpd running as context unconfined_u:system_r:httpd_t:s0 [Thu Apr 24 08:12:31 2014] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec) [Thu Apr 24 08:12:31 2014] [notice] Digest: generating secret for digest authentication ... [Thu Apr 24 08:12:31 2014] [notice] Digest: done [Thu Apr 24 08:12:31 2014] [notice] Apache/2.2.15 (Unix) DAV/2 mod_wsgi/3.2 Python/2.6.6 configured -- resuming normal operations

I fixed the the indentation and the dashboard came up fine.

Thanks!

9lives, thanks for the response. I found the error, it appears DJANGO is just as picky about indentation as PYTHON is. If found and unexcited indentation error in /etc/openstack-dashboard/local_settings

root@controller ~]# tail -n 20 -f /var/log/httpd/error_log
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]   File "/usr/lib/python2.6/site-packages/django/utils/functional.py", line 184, in inner
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]     self._setup()
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]   File "/usr/lib/python2.6/site-packages/django/conf/__init__.py", line 42, in _setup
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]     self._wrapped = Settings(settings_module)
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]   File "/usr/lib/python2.6/site-packages/django/conf/__init__.py", line 93, in __init__
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]     mod = importlib.import_module(self.SETTINGS_MODULE)
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]   File "/usr/lib/python2.6/site-packages/django/utils/importlib.py", line 35, in import_module
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]     __import__(name)
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]   File "/usr/share/openstack-dashboard/openstack_dashboard/wsgi/../../openstack_dashboard/settings.py", line 222, in <module>
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]     from local.local_settings import *  # noqa
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]   File "/usr/share/openstack-dashboard/openstack_dashboard/wsgi/../../openstack_dashboard/local/local_settings.py", line 111
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]      CACHES = {
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]     ^
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]  IndentationError: unexpected indent
[Thu Apr 24 08:12:30 2014] [notice] caught SIGTERM, shutting down
[Thu Apr 24 08:12:31 2014] [notice] SELinux policy enabled; httpd running as context unconfined_u:system_r:httpd_t:s0
[Thu Apr 24 08:12:31 2014] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Thu Apr 24 08:12:31 2014] [notice] Digest: generating secret for digest authentication ...
[Thu Apr 24 08:12:31 2014] [notice] Digest: done
[Thu Apr 24 08:12:31 2014] [notice] Apache/2.2.15 (Unix) DAV/2 mod_wsgi/3.2 Python/2.6.6 configured -- resuming normal operations

operations

I fixed the the indentation and the dashboard came up fine.

Thanks!

9lives, thanks for the response. I found the error, it appears DJANGO is just as picky about indentation as PYTHON is. If found and unexcited unexpected indentation error in /etc/openstack-dashboard/local_settings

root@controller ~]# tail -n 20 -f /var/log/httpd/error_log
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]   File "/usr/lib/python2.6/site-packages/django/utils/functional.py", line 184, in inner
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]     self._setup()
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]   File "/usr/lib/python2.6/site-packages/django/conf/__init__.py", line 42, in _setup
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]     self._wrapped = Settings(settings_module)
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]   File "/usr/lib/python2.6/site-packages/django/conf/__init__.py", line 93, in __init__
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]     mod = importlib.import_module(self.SETTINGS_MODULE)
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]   File "/usr/lib/python2.6/site-packages/django/utils/importlib.py", line 35, in import_module
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]     __import__(name)
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]   File "/usr/share/openstack-dashboard/openstack_dashboard/wsgi/../../openstack_dashboard/settings.py", line 222, in <module>
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]     from local.local_settings import *  # noqa
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]   File "/usr/share/openstack-dashboard/openstack_dashboard/wsgi/../../openstack_dashboard/local/local_settings.py", line 111
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]      CACHES = {
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]     ^
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]  IndentationError: unexpected indent
[Thu Apr 24 08:12:30 2014] [notice] caught SIGTERM, shutting down
[Thu Apr 24 08:12:31 2014] [notice] SELinux policy enabled; httpd running as context unconfined_u:system_r:httpd_t:s0
[Thu Apr 24 08:12:31 2014] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Thu Apr 24 08:12:31 2014] [notice] Digest: generating secret for digest authentication ...
[Thu Apr 24 08:12:31 2014] [notice] Digest: done
[Thu Apr 24 08:12:31 2014] [notice] Apache/2.2.15 (Unix) DAV/2 mod_wsgi/3.2 Python/2.6.6 configured -- resuming normal operations

I fixed the the indentation and the dashboard came up fine.

Thanks!

9lives, thanks for the response. I found the error, it appears DJANGO is just as picky about indentation as PYTHON is. If found and unexpected indentation error in /etc/openstack-dashboard/local_settings

root@controller ~]# tail -n 20 -f /var/log/httpd/error_log
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]   File "/usr/lib/python2.6/site-packages/django/utils/functional.py", line 184, in inner
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]     self._setup()
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]   File "/usr/lib/python2.6/site-packages/django/conf/__init__.py", line 42, in _setup
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]     self._wrapped = Settings(settings_module)
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]   File "/usr/lib/python2.6/site-packages/django/conf/__init__.py", line 93, in __init__
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]     mod = importlib.import_module(self.SETTINGS_MODULE)
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]   File "/usr/lib/python2.6/site-packages/django/utils/importlib.py", line 35, in import_module
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]     __import__(name)
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]   File "/usr/share/openstack-dashboard/openstack_dashboard/wsgi/../../openstack_dashboard/settings.py", line 222, in <module>
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]     from local.local_settings import *  # noqa
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]   File "/usr/share/openstack-dashboard/openstack_dashboard/wsgi/../../openstack_dashboard/local/local_settings.py", line 111
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]      CACHES = {
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]     ^
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]  IndentationError: unexpected indent
[Thu Apr 24 08:12:30 2014] [notice] caught SIGTERM, shutting down
[Thu Apr 24 08:12:31 2014] [notice] SELinux policy enabled; httpd running as context unconfined_u:system_r:httpd_t:s0
[Thu Apr 24 08:12:31 2014] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Thu Apr 24 08:12:31 2014] [notice] Digest: generating secret for digest authentication ...
[Thu Apr 24 08:12:31 2014] [notice] Digest: done
[Thu Apr 24 08:12:31 2014] [notice] Apache/2.2.15 (Unix) DAV/2 mod_wsgi/3.2 Python/2.6.6 configured -- resuming normal operations

I fixed the the indentation and the dashboard came up fine.

Thanks!

9lives, thanks for the response. I found the error, it appears DJANGO is just as picky about indentation as PYTHON is. If I found and an unexpected indentation error in /etc/openstack-dashboard/local_settings

[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]      CACHES = {
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]     ^
[Thu Apr 24 08:08:12 2014] [error] [client 172.16.1.10]  IndentationError: unexpected indent

I fixed the the indentation and the dashboard came up fine.

Thanks!