Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

On Apr 22, 2011, at 10:39 AM, Shweta P wrote:

Question #153751 on OpenStack Compute (nova) changed: https://answers.launchpad.net/nova/+question/153751

Status: Answered => Open

Shweta P is still having a problem: Thanks Vish. As you said it was not a rabbit issue.

I still face the issue though and my ip address in the nova.conf file is right. The machines are able to ping each other.

can you check the ip in your novarc credentials? It should be the same for all euca-commands so it is strange that it isn't working. Are you running from the same place you did euca-run-instances etc.? Did you remember to source your novarc credentials before running the command?

Just to help me troubleshoot please correct me if my understanding is wrong.

When I run the euca-authorize -P icmp -t -1:-1 default on the compute node. It connects to nova-api instance running on my cloud controller right?

Yes

So should the nova-api.log have records of this connection?

If you get connection refused then it won't show in the log because it is probably connecting to the wrong ip

I tried to restart the nova-compute,nova-api,nova-scheduler,nova-network ,nova-objectstore and the libvirt on the cloud controller and restarted the nova-network and nova-compute on the compute node.

The nova-*.log files do not seem to be updated when I restart the services. It should be right?

yes they should be updating assuming that log_path is set properly and you are starting them with nova-api --flagfile=/path/to/flagfile or via upstart scripts

Also I just have one /etc/nova/nova.conf. I do not have a conf file for each of the services above like nova-api.conf .. etc. Is that a problem?

That is fine

Please let me know any other items i need to be verifying.

Thanks

-- You received this question notification because you are a member of Nova Core, which is an answer contact for OpenStack Compute (nova).