Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

You should only be running one rabbitmq server and you should specify that server as the rabbit_host on both machines.


On Apr 21, 2011, at 9:28 AM, Shweta P wrote:

New question #153751 on OpenStack Compute (nova):

I have setup the installations on the controller and one compute node.

When I run the this command after finishing the basic config on both these machinces. I get a connection error.

euca-authorize -P icmp -t -1:-1 default [Errno 111] Connection refused

I am not sure if it is linked, but I checked the status of the rabbitMq server. When I run the command

administrator@ubuntu:~$ sudo rabbitmqctl list_connections Listing connections ... ...done.

It does not list any connections. I restarted the rabbitMQ server on both controller and the compute node. It still does not List any connections.

This is what the last log says

=INFO REPORT==== 21-Apr-2011::11:21:21 === Stop-and-halt request received; halting in 1000 milliseconds

=INFO REPORT==== 21-Apr-2011::11:21:21 === stopped TCP Listener on

=INFO REPORT==== 21-Apr-2011::11:21:21 === application: rabbit exited: stopped type: temporary

=INFO REPORT==== 21-Apr-2011::11:21:21 === application: mnesia exited: stopped type: temporary

=INFO REPORT==== 21-Apr-2011::11:21:21 === application: os_mon exited: stopped type: temporary

Though when I run the status command it does not say it is stopped administrator@ubuntu:~$ sudo rabbitmqctl status Status of node rabbit@ubuntu ... [{running_applications,[{rabbit,"RabbitMQ","1.7.2"}, {mnesia,"MNESIA CXC 138 12","4.4.12"}, {os_mon,"CPO CXC 138 46","2.2.4"}, {sasl,"SASL CXC 138 11","2.1.8"}, {stdlib,"ERTS CXC 138 10","1.16.4"}, {kernel,"ERTS CXC 138 10","2.13.4"}]}, {nodes,[rabbit@ubuntu]}, {running_nodes,[rabbit@ubuntu]}] ...done.

What do I need to do?

-- You received this question notification because you are a member of Nova Core, which is an answer contact for OpenStack Compute (nova).