Revision history [back]

the reason is that the instance mounts a remote volume before, but duo to some reason, now the volume is not exists in the server. so the instance can't be started, also in your nova.conf I guess you set the resume_guests_state_on_host_boot=true or start_guests_on_host_boot=true .so nova-compute can't start .

you can change the two config options to false to prevent nova-compute from start the instances at startup time. or mount the remove volume manually by using iscsiadm