Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Your traffic is probably being snatted, so the metadata server gets the wrong source ip and can't look up info. Try setting --dmz_cidr to the ip address of your api host e.g. --dmz_cidr=192.168.22.1/32 (or wherever your api host is running)

On Feb 27, 2012, at 1:00 PM, Ahmad Al-Shishtawy wrote:

Question #189026 on OpenStack Compute (nova) changed: https://answers.launchpad.net/nova/+question/189026

Ahmad Al-Shishtawy gave more information on the question: When I remove the flag --ec2_dmz_host from the compute node the console output becomes:

cloud-init start-local running: Mon, 27 Feb 2012 20:54:39 +0000. up 1.91 seconds no instance data found in start-local ci-info: lo : 1 127.0.0.1 255.0.0.0
ci-info: eth0 : 1 192.168.22.41 255.255.255.0 02:16:3e:52:1f:dd ci-info: route-0: 0.0.0.0 192.168.22.20 0.0.0.0 eth0 UG ci-info: route-1: 192.168.22.0 0.0.0.0 255.255.255.0 eth0 U cloud-init start running: Mon, 27 Feb 2012 20:54:53 +0000. up 15.14 seconds 2012-02-27 20:55:03,278 - DataSourceEc2.py[WARNING]: 'http://169.254.169.254' failed: url error [[Errno 111] Connection refused] 2012-02-27 20:55:04,282 - DataSourceEc2.py[WARNING]: 'http://169.254.169.254' failed: url error [[Errno 111] Connection refused]

So it seems in the original setup, with the --ec2_dmz_host flag, instances can reach the api server. Why can't find metadata?

-- You received this question notification because you are a member of Nova Core, which is an answer contact for OpenStack Compute (nova).