Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Alright I have some more information, below is a piece of the /etc/quantum/l3_agent.ini file.

Allow overlapping IP (Must have kernel build with CONFIG_NET_NS=y and

iproute2 package that supports namespaces).

use_namespaces = False

If use_namespaces is set as False then the agent can only configure one router.

This is done by setting the specific router_id.

router_id = 296ccc78-1766-41c9-9ead-713a0843070f

I checked the internal ports on router_id "296ccc78-1766-41c9-9ead-713a0843070f" with

quantum port-list -- --device_id=296ccc78-1766-41c9-9ead-713a0843070f

And I saw both the internal port with ip of 10.6.6.1 and the external port with ip 192.168.2.130

Any idea why I'm still not seeing any 10.6.6.1 ip address with ifconfig -a? And yes, you are right I am not using namespaces.