Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Ok, there are a couple of issues here.

First you've got some errors in your service catalog entries, namely the internal urls of your services. They all direct to the nova api, please check that you create your endpoints according to this link: http://docs.openstack.org/essex/openstack-compute/starter/content/Creating_Endpoints-d1e469.html

The next thing is your curl itself to get the token. You use: curl -d '{"auth": {"tenantName": "openstackDemo", "passwordCredentials":{"username": "adminUser", "password": "secretword"}}}' -H "Content-type: application/json" http://XX.XX.XX.XX:35357/v2.0/tokens | python -mjson.tool

It should work, but you're actually using the admin url here. Usually one would use either the internal or the public url for authentication: "http://XX.XX.XX.XX:5000/v2.0"

When you try to validate the glance and nova endpoints, why don't you use the "glance index" and "nova list" commands? Use them with the "--debug" option and they'll show you the http requests they make. Also remember that glance and nova will use their respective users from the service tenant to make those requests. So if you want to check that glance and nova are working correctly using curl than use the credentials of their users.