Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Thanks for your quick response Haneef

I have tried according to your suggestion, but resulted in error again.

Command I have tried is as below

curl -i -X POST http://10.4.230.133:35357/v3/credentials -H "User-Agent: python-keystoneclient" -H "Content-Type: application/json" -H "X-Auth-Token: <token-omitted>" -d'{"credential": { "blob": "{"access": ,,, , "secret": "Secret-"}", "user_id": "64d29e5d86f84440bdd8948ce81a5ae7", "project_id": "f06ea93f31be40f991154a63dedbf300", "type": "ec2"}}' HTTP/1.1 400 Bad Request Vary: X-Auth-Token Content-Type: application/json Content-Length: 244 Date: Thu, 29 Aug 2013 10:36:06 GMT

{"error": {"message": "Expecting to find valid JSON in request body. The server could not comply with the request since it is either malformed or otherwise incorrect. The client is assumed to be in error.", "code": 400, "title": "Bad Request"}}

Other Request bodies I have tried are as below

---- {"credential": {"blob": '{\"access\": \"acceskey\", \"secret\": \"Secret\"}', "user_id": "64d29e5d86f84440bdd8948ce81a5ae7", "project_id": "f06ea93f31be40f991154a63dedbf300", "type": "ec2"}}

---- {"credential": {"blob": "{\"access\": \"acceskey\", \"secret\": \"Secret\"}", "user_id": "64d29e5d86f84440bdd8948ce81a5ae7", "project_id": "f06ea93f31be40f991154a63dedbf300", "type": "ec2"}}

---- {"credential": {"blob": "\{\"access\": \"acceskey\", \"secret\": \"Secret\"\}", "user_id": "64d29e5d86f84440bdd8948ce81a5ae7", "project_id": "f06ea93f31be40f991154a63dedbf300", "type": "ec2"}}

Can you please correct me if I am wrong.

Thanks in advance, Harika