Revision history [back]

click to hide/show revision 1
initial version

Hi Chuck,

Thanks for the prompt response. I did add '' to @endpoint in I tried what you suggested with account hash, but still got the same error:

ghuang@ubuntu:~$ --id test:tester --key testing --get -- -s -v -k Unknown option: get * About to connect() to port 8080 (#0) * Trying connected * Connected to ( port 8080 (#0)

GET /v1.0/ACCOUNTHASH HTTP/1.1 User-Agent: curl/7.19.7 (x86_64-pc-linux-gnu) libcurl/7.19.7 OpenSSL/0.9.8k zlib/ libidn/1.15 Host: Accept: / Date: Thu, 21 Jul 2011 21:47:09 +0000 Authorization: AWS test:tester:V/M/6Qqjpk193D2wIxPULMsztKQ=

< HTTP/1.1 500 Internal Server Error < Content-Type: text/plain < Content-Length: 872 < Date: Thu, 21 Jul 2011 21:47:09 GMT < Connection: close < Traceback (most recent call last): File "/usr/lib/pymodules/python2.6/eventlet/", line 336, in handle_one_response result = self.application(self.environ, start_response) File "/home/ghuang/swift/trunk/swift/common/middleware/", line 38, in __call__ return, start_response) File "/home/ghuang/swift/trunk/swift/common/middleware/", line 32, in __call__ return, start_response) File "/home/ghuang/swift/trunk/swift/common/middleware/", line 133, in __call__ groups = self.get_groups(env, token) File "/home/ghuang/swift/trunk/swift/common/middleware/", line 225, in get_groups msg = base64.urlsafe_b64decode(unquote(token)) File "/usr/lib/python2.6/", line 1170, in unquote res = s.split('%') AttributeError: 'NoneType' object has no attribute 'split' * Closing connection #0 ghuang@ubuntu:~$

I will continue to investigate. Please let me know if you have any other idea that I might do something wrong.