Revision history [back]

click to hide/show revision 1
initial version

I tried jets3t Java API using 'test:tester' as id and 'testing' as key, and got exactly the same error as when I ran s3curl which is [401 Unauthorized]. Can anyone help? Thanks.

Jun 28, 2011 7:59:52 PM org.jets3t.service.impl.rest.httpclient.RestStorageService performRequest WARNING: Error Response: GET '/auth/v1.0/' -- ResponseCode: 401, ResponseStatus: Unauthorized, Request Headers: [Content-Type: , Date: Wed, 29 Jun 2011 02:59:50 GMT, Authorization: AWS test:tester:/fk0olUEoelY4uXJXb6xbW1igRQ=, User-Agent: JetS3t/0.8.1 (Linux/2.6.32-28-generic; amd64; en; JVM 1.6.0_20), Host: 127.0.0.1:8080], Response Headers: [Content-Length: 253, Content-Type: text/plain; charset=UTF-8, Date: Wed, 29 Jun 2011 02:59:52 GMT] Exception in thread "main" org.jets3t.service.S3ServiceException: Request Error [401 Unauthorized

This server could not verify that you are authorized to access the document you requested. Either you supplied the wrong credentials (e.g., bad password), or your browser does not understand how to supply the credentials required.

]. GET '/auth/v1.0/' on Host '127.0.0.1:8080' @ 'Wed, 29 Jun 2011 02:59:52 GMT' -- ResponseCode: 401, ResponseStatus: Unauthorized at org.jets3t.service.S3Service.listAllBuckets(S3Service.java:1375) at org.jets3t.samples.CodeSamples.main(CodeSamples.java:89) Caused by: org.jets3t.service.impl.rest.HttpException at org.jets3t.service.impl.rest.httpclient.RestStorageService.performRequest(RestStorageService.java:525) at org.jets3t.service.impl.rest.httpclient.RestStorageService.performRestGet(RestStorageService.java:911) at org.jets3t.service.impl.rest.httpclient.RestStorageService.listAllBucketsImpl(RestStorageService.java:1302) at org.jets3t.service.StorageService.listAllBuckets(StorageService.java:565) at org.jets3t.service.S3Service.listAllBuckets(S3Service.java:1372) ... 1 more