Revision history [back]

click to hide/show revision 1
initial version

Hypervisor - ESX4.1

Device Switch Ip vmnic1 vSwitch1 230.XXX vmnic0 vSwitch0 249.ZZZ

Build n/w command:

sudo nova-manage network create private --fixed_range_v4=192.168.249.32/27 --num_networks=1 --bridge=vSwitch0 --bridge_interface=eth1 --network_size=32

nova.conf

network specific settings

--network_manager=nova.network.manager.FlatDHCPManager --public_interface=eth0 --flat_interface=eth1 --flat_network_bridge=vSwitch0 --fixed_range=192.168.249.32/27 --floating_range=192.168.230.32/27

ifconfig

eth0 Link encap:Ethernet HWaddr 00:50:56:b9:00:04 inet addr:192.168.230.74 Bcast:192.168.230.255 Mask:255.255.255.0 inet6 addr: fe80::250:56ff:feb9:4/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:21080 errors:0 dropped:0 overruns:0 frame:0 TX packets:21069 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:9862191 (9.8 MB) TX bytes:11808311 (11.8 MB)

root@osserver1:~# ifconfig eth1 eth1 Link encap:Ethernet HWaddr 00:50:56:b9:00:05 inet6 addr: fe80::250:56ff:feb9:5/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:16628 errors:0 dropped:426 overruns:0 frame:0 TX packets:3288 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:1509996 (1.5 MB) TX bytes:1142934 (1.1 MB)

Still same error NetworkNotFoundForBridge: Network could not be found for bridge vSwitch0

Plz check. if above configurations are correct??