Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Changing the endpoint fixed the problem. However, I used glance in default DB mode, which means using sqlite. I did try dropping the DB and doing the glance-manage db_sync. It did put markers in the DB for glance, but none of the tables were there.

-----Original Message----- From: bounces@canonical.com [mailto:bounces@canonical.com] On Behalf Of smallma Sent: Tuesday, April 17, 2012 10:01 PM To: Mize, Donald Subject: Re: [Question #193860]: problem verifying glance

Your question #193860 on Glance changed: https://answers.launchpad.net/glance/+question/193860

smallma posted a new comment: Hello Don, First, you should stop glance and remove DB. And then execute "glance-manage db_sync". at last, you set up glance-api and glance-registry again.

BTW, you endpoint looks like incorrect. Please refer to the following keystone command. and I don't know why there was no paste deploy in glance-api-paste.ini, it's stange. you should check installation steps again. glance-api-paste.ini is very important.

keystone endpoint-create --region RegionOne --service_id XXXXXXXXXXX --publicurl http://172.17.86.9:9292/v1 --adminurl http://172.17.86.9:9292/v1 --internalurl http://172.17.86.9:9292/v1

Regards,

Rain

-- You received this question notification because you asked the question.