Ask Your Question

Revision history [back]

logging

--log_dir = '/var/log/glance' --log_file = 'glance.log' --log-config=/usr/etc/logging.cnf

As I mentioned on http://docs.openstack.org/cactus/openstack-compute/admin/content/configuring-logging-for-glance.html, you need to remove the above lines from your glance.conf. You need to add the following to your glance.conf to enable logging in both the API and Registry servers:

In the [app:glance-api] section, put:

log_file = /var/log/glance/api.log

In the [app:glance-registry] section, put:

log_file = /var/log/glance/registry.log

Restart your servers and logging should be enabled in debug level. After, please post what is in the API log file. Thanks! -jay