Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Thanks Ricardo. I solved the same issue with your comments.

FYI. I tested openstack and quantum on VMs runs on ESXi and got the exactly the same problem with Ricardo. Ping to the qg-xx interface, which resides in a different namespace from the root, failed from external. It only worked inside the same host. Gateway IP and floating IPs were set successfully and I set routing rules properly. By changing vswitch settings on vsphere client, it just worked well.

Refer to this link(http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1004099) to set your VM's network interfaces to promiscuous mode, in case of you're using ESXi.