Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

/etc/rsyslog.conf contains the following to allow any process on the box to send to its listening address via UDP: $ModLoad imudp $UDPServerAddress 10.12.12.28 $UDPServerRun 514 $AllowedSender UDP, 10.12.12.28

/etc/rsyslog.d/50-default.conf contains the following to log locally: .;auth,authpriv.none -/var/log/syslog user.* -/var/log/user.log

/etc/rsyslog.d/remote.conf sends all syslog facility logs to a remote server: . @10.12.12.20:514

I don't think that this has anything to do with the syslog configuration - glance is configured to log to syslog and is working. Glance's config does not have a log_config parameter though, and that's the only difference I'm seeing here.

In /etc/keystone/logging.conf reference is made to the handlers (production,file,devel) and loggers (root,keystone,combined). All loggers are referring to the 'file' handler, and none to the 'production' handler which is what refers to syslog. I suspect that this is the issue but I cannot find a sample configuration where it shows me how to change this successfully.

Which of the loggers (root,keystone,combined) do I need to change? Is the logger determined by the userid that the service runs under, or some other means? I've dug around - even in the python logger documentation but I can't make head or tail of this yet.