Revision history [back]

Hi,

We face a similar issue in our configuration after 48 hours as well. We have been investigating this problem for quite some time: changing tenant, users, etc in glance and/or keystone, but nothing worked out.

And what finally solved the problem -but that we can't explain- was to change in /etc/glance/glance-api.conf: [keystone_authtoken]
auth_host = $IpAddress

to

[keystone_authtoken]
auth_host = 127.0.0.1

We then restarted the glance services and it worked!

To make sure it was this setting affecting our system we restored it to the previous value, however putting this value back to the original IP address didn't broke the system again; it is still running fine. :/

Hope it helps,

Regards,

Hi,

We face a similar issue in our configuration after 48 hours as well. We have been investigating this problem for quite some time: changing tenant, users, etc in glance and/or keystone, but nothing worked out.

And what finally solved the problem -but that we can't explain- was to change in /etc/glance/glance-api.conf: /etc/glance/glance-api.conf:

[keystone_authtoken]
auth_host = $IpAddress

to

[keystone_authtoken]
auth_host = 127.0.0.1

We then restarted the glance services and it worked!

To make sure it was this setting affecting our system we restored it to the previous value, however putting this value back to the original IP address didn't broke the system again; it is still running fine. :/

Hope it helps,

Regards,