Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Sorry problem still exists. Good news is it looks like the arp is trying to go over the gre tunnel. The problem is, the gre endpoint is not responding to the arp request. So here's what I have

Controller - Private IP - eth1 - 10.1.1.1 Compute Node - Private IP - eth1 - 10.1.1.2

OVS Configuration - Controller root@controller:~# ovs-vsctl show 195ff79e-e01a-4e93-84bc-868d8782f284 Bridge br-ex Port "qg-2b9a29bb-4b" Interface "qg-2b9a29bb-4b" type: internal Port "eth2" Interface "eth2" Port br-ex Interface br-ex type: internal Bridge br-tun Port br-tun Interface br-tun type: internal Port patch-int Interface patch-int type: patch options: {peer=patch-tun} Bridge br-int Port patch-tun Interface patch-tun type: patch options: {peer=patch-int} Port "tap882a8e75-ee" tag: 1 Interface "tap882a8e75-ee" type: internal Port "tap4265fa27-08" tag: 4095 Interface "tap4265fa27-08" type: internal Port "eth1" Interface "eth1" Port br-int Interface br-int type: internal Port "qr-1549a07f-3a" tag: 4095 Interface "qr-1549a07f-3a" type: internal ovs_version: "1.4.0+build0"

OVS Configuration - ComputeNode1 root@ComputeNode1:~# ovs-vsctl show 331fd29b-b70f-4f54-983a-d6749f8cf1ed Bridge br-int Port patch-tun Interface patch-tun type: patch options: {peer=patch-int} Port "qvo002cc4c6-47" tag: 1 Interface "qvo002cc4c6-47" Port br-int Interface br-int type: internal Bridge br-tun Port "gre-1" Interface "gre-1" type: gre options: {in_key=flow, out_key=flow, remote_ip="10.1.1.1"} Port patch-int Interface patch-int type: patch options: {peer=patch-tun} Port br-tun Interface br-tun type: internal ovs_version: "1.4.0+build0"

When I ping from the vm private ip of 10.5.5.3 to the gateway I have setup that lives on the l3 agent on the controller. Eth1 on the compute node will arp for eth1s ip on the controller. But eth1 on the controller isn't responding. Refer to the output below. I am seeing a gre port configured on the compute node but I am not seeing one configured on the controller even though my ovs configuration is fine. Refer to the output on the very bottom. Agents are running on both controller and compute node. Any help would be appreciated.

root@controller:~# tcpdump -i eth1 tcpdump: verbose output suppressed, use -v or -vv for full protocol decode listening on eth1, link-type EN10MB (Ethernet), capture size 65535 bytes 12:00:55.884644 ARP, Request who-has 10.1.1.1 tell 10.1.1.2, length 46 12:00:56.880832 ARP, Request who-has 10.1.1.1 tell 10.1.1.2, length 46 12:00:57.880824 ARP, Request who-has 10.1.1.1 tell 10.1.1.2, length 46

[OVS] tenant_network_type = gre

network_vlan_ranges =

tunnel_id_ranges = 1:1000 integration_bridge = br-int tunnel_bridge = br-tun local_ip = 10.1.1.1 enable_tunneling = True [AGENT] root_helper = sudo /usr/bin/quantum-rootwrap /etc/quantum/rootwrap.conf