Revision history [back]

You disabled DHCP. This is why you have no DHCP namespace.

Most images obtain IP addresses from DHCP, and I would bet yours is no exception. I don't know why it doesn't get its IP address from the existing DHCP servers, but most probably they are configured to only serve certain MAC addresses.

You can confirm this by looking at the instance's console log: openstack console log show INSTANCENAME.

You disabled DHCP. This is why you have no DHCP namespace.namespace. DHCP servers run in network namespaces so that they can have overlapping IP address ranges. Without a DHCP server, no namespace is required.

Most images obtain IP addresses from DHCP, and I would bet yours is no exception. I don't know why it doesn't get its IP address from the existing DHCP servers, but most probably they are configured to only serve certain MAC addresses.

You can confirm this by looking at the instance's console log: openstack console log show INSTANCENAME.