Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Hi all,

we finally made the upgrade from Queens to Train and actually skipped Rocky and Stein in between. However, there were a number of issues to be dealt with, so the short answer to this question would be "No, try to avoid it".

The most difficult service in this upgrade was Cinder. Its migrations repository in the Train release starts at version 123, whereas the Queens release was at migration 117. They do that to reduce the size of the migrate_repo. Because of this problem, the upgrade of cinder did not fully work and had to be aided manually by adding the missing migrations from the source code. Watch out, 123 originally introduces a field in the transfers table, so you cannot replace the db_init from Train with a simple no-op migration. I had to manually twiddle with that table to introduce the field in the end, because I hadn't noticed this change. Because of this migration problem, I guess, the cinder (v1) service remained as a registered service, keeping Horizon from displaying instances and volumes properly. Apparently, Horizon prefers the v1 interface, which is not available anymore in Train.

The other parts that I haven't quite solved yet is federated authentication, which seems to be rarely used in OpenStack, but is crucial in our academic environment. Will have to solve that now.

I came across few other issues during the upgrade, but all were solvable and the answers could be found easily on the web:

  1. Upgrade stopped at "Waiting for virtual IP to appear": solution here.
  2. Upgrade stopped at "MariaDB update": a simple mariadb_recovery solved the problem.
  3. Upgrade stopped at "service-ks-register : placement | Creating services": it is not quite clear how I solved this problem in the end. I saw errors in Keystone that led me to believe that SELinux may have caused the problem. In our staging environmen, I also deleted and redeployed the keystone services. In the production environment, this did not help. Was solved in the end, but left an uneasy feeling.

These three problems occured consistently in the staging and production environments. Our staging environment was incomplete and did not have cinder deployed, so those problems went unnoticed during the test run.

I hope this short report is valuable to anyone. My general recommendation remains to not skip releases.

Best regards, Björn