Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

I faced the same issue today. I resolved this by doing the fololwing

in /etc/neutron/api-paste.ini under [filter:authtoken] section I commented out all other settings and used the ones shown below

    [filter:authtoken]
    #paste.filter_factory = keystoneclient.middleware.auth_token:filter_factory
    #auth_host=necon02
    #auth_uri=http://necon02:5000/v2.0
    #admin_user=neutron
    #admin_tenant_name=service
    #admin_password=openstack
    #auth_version = v2.0
    paste.filter_factory = keystoneclient.middleware.auth_token:filter_factory
    delay_auth_decision = true
    auth_host = necon02
    admin_user = neutron
    admin_tenant_name = service
    admin_password = password

in /etc/neutron/neutron.conf under [keystone_authtoken] I commented out all other settings and used the ones shown below

[keystone_authtoken]
#auth_host = necon02
#admin_tenant_name = service
#admin_user = neutron
#admin_password = openstack
#auth_url = http://necon02:35357/v2.0
#auth_strategy = keystone
**auth_uri = http://necon02:5000**
auth_host = necon02
auth_port = 35357
auth_protocol = http
admin_tenant_name = service
admin_user = neutron
admin_password = openstack

I think the primary reason for the issue is that the neutron api is trying to initiate communiction with keystone api on a port 35357 as per auth_url = http://necon02:35357/v2.0, but the keystone api as per the documentaion is configured to receive inital requires on port 5000.

I found this by looking at the keystone_authtoken section of other services (eg;- nova &glance) and comparing them with what was configured for neutron.conf.

After making these change my horizon dashboard is also working and I can create netwroking using CLI an GUI both.

Yay yay !! Hope this helps !! :-) !!

Shiv !