Ask Your Question

Revision history [back]

Have you installed the VNC proxy server on the compute servers? https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/5/html/Installation_and_Configuration_Guide/sect-Install_a_Compute_VNC_Proxy.html

If yes, You should have on both controller and compute the following: novncproxy_host=$host novncproxy_port=$port enabled = true // optional server_listen = $my_ip server_proxyclient_address = $my_ip

And for compute servers at the end of the line the following novncproxy_base_url = http://controller:6080/vnc_auto.html

That should work. hopefully :D

Have you installed the VNC proxy server on the compute servers?

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/5/html/Installation_and_Configuration_Guide/sect-Install_a_Compute_VNC_Proxy.html

If yes, You should have on both controller and compute the following: following:

novncproxy_host=$host
novncproxy_port=$port
enabled = true // optional
server_listen = $my_ip
server_proxyclient_address = $my_ip

$my_ip

And for compute servers at the end of the line the following following:

novncproxy_base_url = http://controller:6080/vnc_auto.html

http://controller:6080/vnc_auto.html

That should work. hopefully :D

Have you installed the VNC proxy server on the compute servers?

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/5/html/Installation_and_Configuration_Guide/sect-Install_a_Compute_VNC_Proxy.html

If yes, You should have on both controller and compute the following:

novncproxy_host=$host
novncproxy_port=$port
enabled = true // optional
server_listen = $my_ip
server_proxyclient_address = $my_ip

And for compute servers at the end of the line the following:

novncproxy_base_url = http://controller:6080/vnc_auto.html
http://controller:<port>/vnc_auto.html

That should work. hopefully :D