Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

The ceph docs state:

show_multiple_locations = True show_image_direct_url = True

This only seems to be relevant for Mitaka, for other releases only show_image_direct_url = true is necessary. But I'm running Ocata and just recently I changed show_multiple_locations to false, since the config description reports it as deprecated. But then I got error messages from nova during (live) snapshot creation

ImageNotAuthorized: Not authorized for <IMAGE>

and had to switch that option back to true. Now the snapshots are working again. I'm not sure if this is a bug in Ocata or if I missed something during the upgrades from Mitaka to Ocata.

The ceph docs state:

show_multiple_locations = True show_image_direct_url = True

This only seems to be relevant for Mitaka, for other releases only show_image_direct_url = true is necessary. But I'm running Ocata and just recently I changed show_multiple_locations to false, since the config description reports it as deprecated. But then I got error messages from nova during (live) snapshot creation

ImageNotAuthorized: Not authorized for <IMAGE>

and had to switch that option back to true. Now the snapshots are working again. I'm not sure if this is a bug in Ocata or if I missed something during the upgrades from Mitaka to Ocata.

EDIT: I found the problem in my environment. The solution is here. Setting cache_image = none on all compute nodes (/etc/nova/nova.conf) disabled the local cache in the local filesystem on the compute nodes (/var/lib/nova/instances/_base).

I believe my issue was the following: I had launched a couple of instances with a wrong base image property (not raw). So the compute node(s) created a base file locally and uploaded the falt image back to Ceph. After fixing the raw format issue nothing changed for the compute nodes, for some reason they still needed to have a local copy, maybe some metadata somewhere, I couldn't really find out. Anyway, after I found the mentioned thread (actually I'm wondering why it took me so long, it seems pretty obvious now) I disabled the cache_image option and restarted all compute services. Launching a new instance from the same base image as before doesn't result in a flat image anymore, it's a copy-on-write clone now, just like it's supposed to be.