Ask Your Question

Revision history [back]

Your Neutron log contains

2018-11-26 12:49:11.524 2261 ERROR neutron.plugins.ml2.managers [req-8702d340-da32-4e78-8f47-7f67294a131e ab6ad8a6ab9b4eff85e0438de6cbf1a7 2b35c39f3f744ea18aee07c8f2d4124e - default default] Failed to bind port 93122ccb-bcea-46ca-9e6e-a16f968406f4 on host computestack for vnic_type normal using segments [{'network_id': 'b7a8108c-63b5-4c67-9960-07c1cf8b9ca0', 'segmentation_id': None, 'physical_network': u'eth0', 'id': '90e498d9-8a43-4509-8da5-2bb6145f0615', 'network_type': u'flat'}]

Note the physical_network: It's called eth0.

In both Linuxbridge configs, however, you have

physical_interface_mappings = provider:eth1

Here, the physical network is named provider.

When you created the external network, you should have used option --provider-physical-network provider, not --provider-physical-network eth0. I wonder, by the way, why Neutron allowed you to use an invalid provider network name. Perhaps I miss something.