Ask Your Question

Revision history [back]

The command is metric list, not meter list.

I believe that, by default, you need to be admin to show metrics.

The command is metric list, not meter list.

I believe that, by default, you need to be admin to show metrics.metrics. Don't ask my why; I am just talking from experience.

The command is metric list, not meter list. Your config looks good, except that you may want to add CEILOMETER_BACKEND=gnocchi, but perhaps that is the default anyway.

I believe that, by default, you need to be admin to show metrics. Don't ask my why; I am just talking from experience.

The command is metric list, not meter list. Your config looks good, except that you may want to add CEILOMETER_BACKEND=gnocchi, but perhaps that is the default anyway.

I believe that, by default, you need to be admin to show metrics. Don't ask my why; I am just talking from experience.

I have a stable/rocky Devstack. My local.conf (password setting omitted):

$ cat devstack/local.conf
[[local|localrc]]

enable_service c-bak
enable_service swift

enable_plugin heat https://git.openstack.org/openstack/heat stable/rocky
enable_service h-eng h-api h-api-cfn h-api-cw

CEILOMETER_BACKEND=gnocchi
enable_plugin ceilometer https://git.openstack.org/openstack/ceilometer stable/rocky
enable_plugin aodh https://git.openstack.org/openstack/aodh stable/rocky

As demo, I can't list the metrics. As admin, I can:

stack@rocky:~$ . devstack/openrc demo demo
WARNING: setting legacy OS_TENANT_NAME to support cli tools.
stack@rocky:~$ gnocchi metric list

stack@rocky:~$ . devstack/openrc admin admin
WARNING: setting legacy OS_TENANT_NAME to support cli tools.
stack@rocky:~$ gnocchi metric list
+--------------------------------------+---------------------+--------------------------------------------+-----------+--------------------------------------+
| id                                   | archive_policy/name | name                                       | unit      | resource_id                          |
+--------------------------------------+---------------------+--------------------------------------------+-----------+--------------------------------------+
| 01090368-a664-4677-958f-3599879fba81 | low                 | storage.objects                            | object    | d6fe17c5-c064-425f-b788-d161ece31fad |
| 0b26c78b-fe3f-45a5-aba6-88fd0184c27e | low                 | volume.provider.capacity.total             | GB        | d152bac4-7a69-507a-9934-8a9468522ff6 |
(....)

The command is metric list, not meter list. Your config looks good, except that you may want to add CEILOMETER_BACKEND=gnocchi, but perhaps that is the default anyway.

I believe that, It looks like, by default, you need to be admin admin to show metrics. Don't ask my why; why.

Two days ago, I am just talking from experience.

I have deployed a stable/rocky Devstack. My local.conf (password setting omitted):

$ cat devstack/local.conf
[[local|localrc]]

enable_service c-bak
enable_service swift

enable_plugin heat https://git.openstack.org/openstack/heat stable/rocky
enable_service h-eng h-api h-api-cfn h-api-cw

CEILOMETER_BACKEND=gnocchi
enable_plugin ceilometer https://git.openstack.org/openstack/ceilometer stable/rocky
enable_plugin aodh https://git.openstack.org/openstack/aodh stable/rocky

As demo, I can't list the metrics. As admin, I can:

stack@rocky:~$ . devstack/openrc demo demo
WARNING: setting legacy OS_TENANT_NAME to support cli tools.
stack@rocky:~$ gnocchi metric list

stack@rocky:~$ . devstack/openrc admin admin
WARNING: setting legacy OS_TENANT_NAME to support cli tools.
stack@rocky:~$ gnocchi metric list
+--------------------------------------+---------------------+--------------------------------------------+-----------+--------------------------------------+
| id                                   | archive_policy/name | name                                       | unit      | resource_id                          |
+--------------------------------------+---------------------+--------------------------------------------+-----------+--------------------------------------+
| 01090368-a664-4677-958f-3599879fba81 | low                 | storage.objects                            | object    | d6fe17c5-c064-425f-b788-d161ece31fad |
| 0b26c78b-fe3f-45a5-aba6-88fd0184c27e | low                 | volume.provider.capacity.total             | GB        | d152bac4-7a69-507a-9934-8a9468522ff6 |
(....)

The command is metric list, not meter list. Your config looks good, except that you may want to add CEILOMETER_BACKEND=gnocchi, but perhaps that is the default anyway.

It looks like, by default, you need to be admin to show metrics. Don't ask my why.

Two days ago, I deployed a stable/rocky Devstack. My local.conf (password setting omitted):

$ cat devstack/local.conf
[[local|localrc]]

enable_service c-bak
enable_service swift

enable_plugin heat https://git.openstack.org/openstack/heat stable/rocky
enable_service h-eng h-api h-api-cfn h-api-cw

CEILOMETER_BACKEND=gnocchi
enable_plugin ceilometer https://git.openstack.org/openstack/ceilometer stable/rocky
enable_plugin aodh https://git.openstack.org/openstack/aodh stable/rocky

As demo, I can't list the metrics. As admin, I can:

stack@rocky:~$ . devstack/openrc demo demo
WARNING: setting legacy OS_TENANT_NAME to support cli tools.
stack@rocky:~$ gnocchi metric list

stack@rocky:~$ . devstack/openrc admin admin
WARNING: setting legacy OS_TENANT_NAME to support cli tools.
stack@rocky:~$ gnocchi metric list
+--------------------------------------+---------------------+--------------------------------------------+-----------+--------------------------------------+
| id                                   | archive_policy/name | name                                       | unit      | resource_id                          |
+--------------------------------------+---------------------+--------------------------------------------+-----------+--------------------------------------+
| 01090368-a664-4677-958f-3599879fba81 | low                 | storage.objects                            | object    | d6fe17c5-c064-425f-b788-d161ece31fad |
| 0b26c78b-fe3f-45a5-aba6-88fd0184c27e | low                 | volume.provider.capacity.total             | GB        | d152bac4-7a69-507a-9934-8a9468522ff6 |
(....)

Note that in order to limit the load, metric list only shows 50 metrics at a time. Use pagination to step through the list; the command line arguments are --marker and --limit.

The command is metric list, not meter list. Your config looks good, except that you may want to add CEILOMETER_BACKEND=gnocchi, but perhaps that is the default anyway.

It looks like, by default, you need to be admin to show metrics. Don't ask my why.

Two days ago, I deployed a stable/rocky Devstack. My local.conf (password setting omitted):

$ cat devstack/local.conf
[[local|localrc]]

enable_service c-bak
enable_service swift

enable_plugin heat https://git.openstack.org/openstack/heat stable/rocky
enable_service h-eng h-api h-api-cfn h-api-cw

CEILOMETER_BACKEND=gnocchi
enable_plugin ceilometer https://git.openstack.org/openstack/ceilometer stable/rocky
enable_plugin aodh https://git.openstack.org/openstack/aodh stable/rocky

As demo, I can't list the metrics. As admin, I can:

stack@rocky:~$ . devstack/openrc demo demo
WARNING: setting legacy OS_TENANT_NAME to support cli tools.
stack@rocky:~$ gnocchi metric list

stack@rocky:~$ . devstack/openrc admin admin
WARNING: setting legacy OS_TENANT_NAME to support cli tools.
stack@rocky:~$ gnocchi metric list
+--------------------------------------+---------------------+--------------------------------------------+-----------+--------------------------------------+
| id                                   | archive_policy/name | name                                       | unit      | resource_id                          |
+--------------------------------------+---------------------+--------------------------------------------+-----------+--------------------------------------+
| 01090368-a664-4677-958f-3599879fba81 | low                 | storage.objects                            | object    | d6fe17c5-c064-425f-b788-d161ece31fad |
| 0b26c78b-fe3f-45a5-aba6-88fd0184c27e | low                 | volume.provider.capacity.total             | GB        | d152bac4-7a69-507a-9934-8a9468522ff6 |
(....)

Note that in order to limit the load, metric list only shows 50 metrics at a time. Use pagination to step through the entire list; the command line arguments are --marker and --limit.