Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Almost immediately after I commented your question I found an answer for one part of my problem.

First, there's the deprecated [memcache] section. Mitaka already reported the deprecation warning as from Pike so we assumed our setup should still work, but it didn't. As soon as we switched to oslo.cache - [cache] section in keystone.conf - memcached worked as expected. We upgraded to Ocata in the meantime.

Second, the HA setup. I'm currently gathering information for a HA setup where I tried to identify necessary steps. I'll have to configure the clients to use multiple servers, so configuring memcached to use localhost has to be changed, but into what? I tried to use the management ip address as suggested by the install guide, which seems reasonable, but configuring the dashboard and keystone.conf accordingly lead to errors in /var/log/apache2/openstack-dashboard-error_log:

[wsgi:error] [pid 12265] Login successful for user "admin", remote address <MY_IP>.
[wsgi:error] [pid 12265] Internal Server Error: /auth/login/
[wsgi:error] [pid 12265] Traceback (most recent call last):
[...]
[wsgi:error] [pid 12265]     "Unable to create a new session key. "
[wsgi:error] [pid 12265] RuntimeError: Unable to create a new session key. It is likely that the cache is unavailable.

I found [1] and simpy tried both, localhost AND management ip, and it worked!

control:~ # grep MEMCACHED_PARAMS /etc/sysconfig/memcached
MEMCACHED_PARAMS="-l 127.0.0.1,<MANAGEMENT_IP>"

Of course, I don't know yet if this is the solution for the to-be-HA setup, but this actually both enabled caching and significantly improved the horizon dashboard performance. I had a bug reported for the poor performance two years ago [2]. It turned out to be both a documentation and a configuration issue.

[1] https://ask.openstack.org/en/question/109273/memcachedservice-is-active-but-in-the-haproxy-web-page-they-are-down

[2] https://bugs.launchpad.net/keystone/+bug/1587777