Ask Your Question

Revision history [back]

The Keystone CLI only supports the v2 Keystone API. The unified OpenStack CLI will support the v3 Keystone API. Note that per the --help message the standalone Keystone CLI client is marked for deprecation, to be replaced by the unified OpenStack CLI:

This CLI is pending deprecation in favor of python-openstackclient. For a
Python library, continue using python-keystoneclient.

See also: https://lists.launchpad.net/openstack/msg20811.html

The Keystone CLI client only supports the v2 Keystone API. The link:unified OpenStack CLI CLI will support the v3 Keystone API. API.

Note that per the --help message the standalone Keystone CLI client is marked for deprecation, to be replaced by the unified OpenStack CLI:

This CLI is pending deprecation in favor of python-openstackclient. For a
Python library, continue using python-keystoneclient.

To try out the unified client you can either:

or

  • Install the link:RDO package for EL-derived distributions or Fedora:

    • EL6:

    $ yum install -y http://repos.fedorapeople.org/repos/openstack/openstack-havana/epel-6/python-openstackclient-0.2.2-4.el6.noarch.rpm

    • Fedora:

    $ yum install -y http://repos.fedorapeople.org/repos/openstack/openstack-havana/fedora-19/python-openstackclient-0.3.0-1.fc20.noarch.rpm

or

  • Install the

See also: https://lists.launchpad.net/openstack/msg20811.html

The Keystone CLI client only supports the v2 Keystone API. The link:unified OpenStack CLI will support the v3 Keystone API.

Note that per the --help message the standalone Keystone CLI client is marked for deprecation, to be replaced by the unified OpenStack CLI:

This CLI is pending deprecation in favor of python-openstackclient. For a
Python library, continue using python-keystoneclient.

To try out the unified client you can either:

or

  • Install the link:RDO package for EL-derived distributions or Fedora:

    • EL6:

    $ # yum install -y http://repos.fedorapeople.org/repos/openstack/openstack-havana/epel-6/python-openstackclient-0.2.2-4.el6.noarch.rpm

    • Fedora:

    $ # yum install -y http://repos.fedorapeople.org/repos/openstack/openstack-havana/fedora-19/python-openstackclient-0.3.0-1.fc20.noarch.rpm

or

  • Install the

See also: https://lists.launchpad.net/openstack/msg20811.html

The Keystone CLI client only supports the v2 Keystone API. The link:unified OpenStack CLI will support the v3 Keystone API.

Note that per the --help message the standalone Keystone CLI client is marked for deprecation, to be replaced by the unified OpenStack CLI:

This CLI is pending deprecation in favor of python-openstackclient. For a
Python library, continue using python-keystoneclient.

To try out the unified client you can either:

or

  • Install the link:RDO package for EL-derived distributions or Fedora:

    • EL6:

    # yum install -y http://repos.fedorapeople.org/repos/openstack/openstack-havana/epel-6/python-openstackclient-0.2.2-4.el6.noarch.rpm

    • Fedora:

    # yum install -y http://repos.fedorapeople.org/repos/openstack/openstack-havana/fedora-19/python-openstackclient-0.3.0-1.fc20.noarch.rpm

See also: https://lists.launchpad.net/openstack/msg20811.html

The Keystone CLI client only supports the v2 Keystone API. The link:unified OpenStack CLI will support the v3 Keystone API.

Note that per the --help message the standalone Keystone CLI client is marked for deprecation, to be replaced by the unified OpenStack CLI:

This CLI is pending deprecation in favor of python-openstackclient. For a
Python library, continue using python-keystoneclient.

To try out the unified client you can either:

or

  • Install the link:RDO package for EL-derived distributions or Fedora:

    • EL6:

    # yum install -y http://repos.fedorapeople.org/repos/openstack/openstack-havana/epel-6/python-openstackclient-0.2.2-4.el6.noarch.rpm

    • Fedora:

    # yum install -y http://repos.fedorapeople.org/repos/openstack/openstack-havana/fedora-19/python-openstackclient-0.3.0-1.fc20.noarch.rpm

See also: https://lists.launchpad.net/openstack/msg20811.html

The Keystone CLI client only supports the v2 Keystone API. The unified OpenStack CLI will support the v3 Keystone API.

Note that per the --help message the standalone Keystone CLI client is marked for deprecation, to be replaced by the unified OpenStack CLI:

This CLI is pending deprecation in favor of python-openstackclient. For a
Python library, continue using python-keystoneclient.

To try out the unified client you can either:

or

  • Install the RDO package for EL-derived distributions or Fedora:

    • EL6:

    # yum install -y http://repos.fedorapeople.org/repos/openstack/openstack-havana/epel-6/python-openstackclient-0.2.2-4.el6.noarch.rpm

    • Fedora:

    # yum install -y http://repos.fedorapeople.org/repos/openstack/openstack-havana/fedora-19/python-openstackclient-0.3.0-1.fc20.noarch.rpm

or

See also: https://lists.launchpad.net/openstack/msg20811.html

The Keystone CLI client only supports the v2 Keystone API. The unified OpenStack CLI will support the v3 Keystone API.

Note that per the --help message the standalone Keystone CLI client is marked for deprecation, to be replaced by the unified OpenStack CLI:

This CLI is pending deprecation in favor of python-openstackclient. For a
Python library, continue using python-keystoneclient.

To try out the unified client you can either:

or

  • Install the RDO package for EL-derived distributions or Fedora:

    • EL6:

    # yum install -y http://repos.fedorapeople.org/repos/openstack/openstack-havana/epel-6/python-openstackclient-0.2.2-4.el6.noarch.rpm

    • Fedora:

    # yum install -y http://repos.fedorapeople.org/repos/openstack/openstack-havana/fedora-19/python-openstackclient-0.3.0-1.fc20.noarch.rpm

or

See also: https://lists.launchpad.net/openstack/msg20811.html

The Keystone CLI client only supports the v2 Keystone API. The unified OpenStack CLI will ultimately support the v3 Keystone API.API, although it's not clear if it fully supports it yet today.

Note that per the --help message the standalone Keystone CLI client is marked for deprecation, to be replaced by the unified OpenStack CLI:

This CLI is pending deprecation in favor of python-openstackclient. For a
Python library, continue using python-keystoneclient.

To try out the unified client you can either:

or

  • Install the RDO package for EL-derived distributions or Fedora:

    • EL6:

    # yum install -y http://repos.fedorapeople.org/repos/openstack/openstack-havana/epel-6/python-openstackclient-0.2.2-4.el6.noarch.rpm

    • Fedora:

    # yum install -y http://repos.fedorapeople.org/repos/openstack/openstack-havana/fedora-19/python-openstackclient-0.3.0-1.fc20.noarch.rpm

or

See also: https://lists.launchpad.net/openstack/msg20811.html

The Keystone CLI client only supports the v2 Keystone API. The unified OpenStack CLI will ultimately support the v3 Keystone API, although it's not clear if it fully supports it yet today.

Note that per the --help message the standalone Keystone CLI client is marked for deprecation, to be replaced by the unified OpenStack CLI:

This CLI is pending deprecation in favor of python-openstackclient. For a
Python library, continue using python-keystoneclient.

To try out the unified client you can either:

or

  • Install the RDO package for EL-derived distributions or Fedora:

    • EL6:

    # yum install -y http://repos.fedorapeople.org/repos/openstack/openstack-havana/epel-6/python-openstackclient-0.2.2-4.el6.noarch.rpm

    • Fedora:

    # yum install -y http://repos.fedorapeople.org/repos/openstack/openstack-havana/fedora-19/python-openstackclient-0.3.0-1.fc20.noarch.rpm

or

See also: https://lists.launchpad.net/openstack/msg20811.html

The Keystone CLI client only supports the v2 Keystone API. The unified OpenStack CLI will ultimately support the v3 Keystone API, although it's not clear if it fully supports it yet today.

Note that per the --help message the standalone Keystone CLI client is marked for deprecation, to be replaced by the unified OpenStack CLI:

This CLI is pending deprecation in favor of python-openstackclient. For a
Python library, continue using python-keystoneclient.

To try out the unified client you can either:

or

  • Install the RDO package for EL-derived distributions or Fedora:

    • EL6:

    # yum install -y http://repos.fedorapeople.org/repos/openstack/openstack-havana/epel-6/python-openstackclient-0.2.2-4.el6.noarch.rpm

    • Fedora:

    # yum install -y http://repos.fedorapeople.org/repos/openstack/openstack-havana/fedora-19/python-openstackclient-0.3.0-1.fc20.noarch.rpm

or

See also: https://lists.launchpad.net/openstack/msg20811.html