Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

As Bernd commented... This is not the root cause of the issue.

To find the root cause , check sudo journalctl -u devstack@n- and look for the last error that has occurred. In my case the error was AttributeError: 'module' object has no attribute 'GSSException' I removed the python-gssapi.x86_64 using the command yum remove python-gssapi.x86_64 and this issue was resolved. But another error popped up. This was due to a missing python module. ImportError: No module named pyasn1.type.univ So installed the module python-pyasn1 and python-pyasn1-modules using command yum install python-pyasn1 python-pyasn1-modules*.

After doing this, to test, I started only the nova-api (The service that threw these errors) and the service came up.

So the issue was fixed now. After this simply run the below get going ./unstack.sh and ./stack.sh

As Bernd commented... This is not the root cause of the issue.

To find the root cause , check sudo journalctl -u devstack@n- and look for the last error that has occurred. In my case the error was AttributeError: 'module' object has no attribute 'GSSException' I removed the python-gssapi.x86_64 using the command yum remove python-gssapi.x86_64 and this issue was resolved. But another error popped up. This was due to a missing python module. ImportError: No module named pyasn1.type.univ So installed the module python-pyasn1 and python-pyasn1-modules using command yum install python-pyasn1 python-pyasn1-modules*.

After doing this, to test, I started only the nova-api (The service that threw these errors) and the service came up.

So the issue was fixed now. After this simply run the below get going ./unstack.sh and ./stack.sh