Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Hi, you can control that with the image's metadata:

control:~ # openstack image set --property hw_scsi_model=virtio-scsi --property hw_disk_bus=scsi --property hw_qemu_guest_agent=yes --property os_require_quiesce=yes 8a143d74-565f-47d8-b10d-0dd5842976aa

This will enable devices like /dev/sdX. Maybe this is the default in your environment, if I just remove these properties from the base image my instances get their /dev/vdX devices. You should take look into your configs, maybe you have defined some default image properties. You can disable these properties per image bye simply running:

control:~ # openstack image set --remove-property hw_scsi_model --remove-property hw_disk_bus --remove-property hw_qemu_guest_agent --remove-property os_require_quiesce 8a143d74-565f-47d8-b10d-0dd5842976aa

Hope this helps!