Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Hello again, I have been doing some checks and today I found that they have updated on yesterday 09/11/2017 the openstack guide for ubuntu 16.04 and the pike version in which they include how to install and configure gnocchi .

https://docs.openstack.org/ceilometer...

Anyway I realized that the user created gnocchi trying to add to the service project and role of admin I came to jump the errors of ceilometer-upgrade, all this with previous execution of both gnocchi-api and gnocchi-metricd. It is possible that the error I give you at http://paste.openstack.org/show/625930/ may come around but it depends on the configuration you have in gnocchi and ceilometer.

With any news I inform without problems and I expose the solutions that go seeing ..

Regards,

Hello again, I have been doing some checks and today I found that they have updated on yesterday 09/11/2017 the openstack guide for ubuntu 16.04 and the pike version in which they include how to install and configure gnocchi .

https://docs.openstack.org/ceilometer...

Anyway I realized that the user created gnocchi trying to add to the service project and role of admin I came to jump the errors of ceilometer-upgrade, all this with previous execution of both gnocchi-api and gnocchi-metricd. It is possible that the error I give you at http://paste.openstack.org/show/625930/ may come around but it depends on the configuration you have in gnocchi and ceilometer.

With


I have tried to install again ceilometer and gnocchi with the new openstack changes regarding the official guide.

https://docs.openstack.org/ceilometer/pike/install/install-base-ubuntu.html

I have managed to carry out all the steps, but there are some things that I have had to do in at least some. I still have some problem to solve.

"In the [storage] section, configure location to store metric data, in this case, we will store it to the local file system. See Gnocchi documentation for a list of more durable and performant drivers:"

[storage] coordination_url = redis: // controller: 6379 file_basepath = / var / lib / gnocchi driver = file

I was testing but at the time of executing the gnocchi-upgrade command I got connectivity errors with coordination_url.

It is necessary to install redis-server can be carried out with the command apt-get install redis-server without problem and have also installed the redis python module with pip install redis.

Then in /etc/redis/redis.conf I have changed the ip address set for the redis server (127.0.0.1) by the cloud management address of the controller.

I tried the gnocchi-upgrade command again and it did not return any news I inform without problems and I expose the solutions that go seeing ..errors.

Anyway, when I run the command "ceilometer-upgrade --skip-metering-database" it returns the following errors ...

2017-11-10 11: 55: 18.933 5401 WARNING oslo_reports.guru_meditation_report [-] Guru meditation now registers SIGUSR1 and SIGUSR2 by default for backward compatibility. SIGUSR1 will no longer be registered in a future release, so please use SIGUSR2 to generate reports. 2017-11-10 11: 55: 18.934 5401 INFO ceilometer.cmd.storage [-] Skipping metering database upgrade 2017-11-10 11: 55: 19.859 5401 CRITICAL ceilometer [-] Unhandled error: Forbidden: <html> <head> <title> 403 Forbidden <body>

Forbidden

You do not have permission to access / v1 / resource_type / ceph_account on this server.


Apache / 2.4.18 (Ubuntu) Server at controller Port 8041 (HTTP 403) 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer Traceback (most recent call last): 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer File "/ usr / bin / ceilometer-upgrade", line 10, in <module> 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer sys.exit (upgrade ()) 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer File "/usr/lib/python2.7/dist-packages/ceilometer/cmd/storage.py", line 59, in upgrade 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer gnocchi_client.upgrade_resource_types (conf) 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer File "/usr/lib/python2.7/dist-packages/ceilometer/gnocchi_client.py", line 194, in upgrade_resource_types 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer gnocchi.resource_type.get (name = name) 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer File "/usr/lib/python2.7/dist-packages/gnocchiclient/v1/resource_type.py", line 44, in get 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer headers = {'Content-Type': "application / json"}). Json () 2017-11-10 11: 55: 19859 5401 ERROR ceilometer File "/usr/lib/python2.7/dist-packages/gnocchiclient/v1/base.py", line 37, in _get 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer return self.client.api.get (* args, * kwargs) 2017-11-10 11: 55: 19859 5401 ERROR ceilometer File "/usr/lib/python2.7/dist-packages/keystoneauth1/adapter.py", line 288, in get 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer return self.request (url, 'GET', * kwargs) 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer File "/usr/lib/python2.7/dist-packages/gnocchiclient/client.py", line 38, in request 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer raise exceptions.from_response (resp, method) 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer Forbidden: 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer <html> <head> 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer <title> 403 Forbidden 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer <body> 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer

Forbidden 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer

You do not have permission to access / v1 / resource_type / ceph_account 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer on this server.
2017-11-10 11: 55: 19.859 5401 ERROR ceilometer 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer


2017-11-10 11: 55: 19.859 5401 ERROR ceilometer
Apache / 2.4.18 (Ubuntu) Server at controller Port 8041 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer (HTTP 403) 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer

I do not know what the problem may be ... :-(

I do not know if it is necessary to add gnocchi with admin role and service project

Regards,

Hello again, I have been doing some checks and today I found that they have updated on yesterday 09/11/2017 the openstack guide for ubuntu 16.04 and the pike version in which they include how to install and configure gnocchi .

https://docs.openstack.org/ceilometer...

Anyway I realized that the user created gnocchi trying to add to the service project and role of admin I came to jump the errors of ceilometer-upgrade, all this with previous execution of both gnocchi-api and gnocchi-metricd. It is possible that the error I give you at http://paste.openstack.org/show/625930/ may come around but it depends on the configuration you have in gnocchi and ceilometer.


I have tried to install again ceilometer and gnocchi with the new openstack changes regarding the official guide.

https://docs.openstack.org/ceilometer/pike/install/install-base-ubuntu.html

I have managed to carry out all the steps, but there are some things that I have had to do in at least some. I still have some problem to solve.

"In the [storage] section, configure location to store metric data, in this case, we will store it to the local file system. See Gnocchi documentation for a list of more durable and performant drivers:"

[storage] coordination_url = redis: // controller: 6379 file_basepath = / var / lib / gnocchi driver = file

I was testing but at the time of executing the gnocchi-upgrade command I got connectivity errors with coordination_url.

It is necessary to install redis-server can be carried out with the command apt-get install redis-server without problem and have also installed the redis python module with pip install redis.

Then in /etc/redis/redis.conf I have changed the ip address set for the redis server (127.0.0.1) by the cloud management address of the controller.

I tried the gnocchi-upgrade command again and it did not return any errors.

Anyway, when I run the command "ceilometer-upgrade --skip-metering-database" it returns the following errors ...

2017-11-10 11: 55: 18.933 5401

WARNING oslo_reports.guru_meditation_report [-] Guru meditation now registers SIGUSR1 and SIGUSR2 by default for backward compatibility. SIGUSR1 will no longer be registered in a future release, so please use SIGUSR2 to generate reports. 2017-11-10 11: 55: 18.934 11:55:18.934 5401 INFO ceilometer.cmd.storage [-] Skipping metering database upgrade 2017-11-10 11: 55: 19.859 11:55:19.859 5401 CRITICAL ceilometer [-] Unhandled error: Forbidden: <html> <head> <title> 403 Forbidden <body>

Forbidden

<html><head> <title>403 Forbidden</title> </head><body> Forbidden

You do not don't have permission to access / v1 / resource_type / ceph_account /v1/resource_type/ceph_account on this server. server.


Apache / 2.4.18 Apache/2.4.18 (Ubuntu) Server at controller Port 8041 8041
</body></html> (HTTP 403) 2017-11-10 11: 55: 19.859 11:55:19.859 5401 ERROR ceilometer Traceback (most recent call last): 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer 11:55:19.859 5401 ERROR ceilometer File "/ usr / bin / ceilometer-upgrade", "/usr/bin/ceilometer-upgrade", line 10, in <module> 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer sys.exit (upgrade ()) 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer 11:55:19.859 5401 ERROR ceilometer sys.exit(upgrade()) 2017-11-10 11:55:19.859 5401 ERROR ceilometer File "/usr/lib/python2.7/dist-packages/ceilometer/cmd/storage.py", line 59, in upgrade 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer gnocchi_client.upgrade_resource_types (conf) 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer 11:55:19.859 5401 ERROR ceilometer gnocchi_client.upgrade_resource_types(conf) 2017-11-10 11:55:19.859 5401 ERROR ceilometer File "/usr/lib/python2.7/dist-packages/ceilometer/gnocchi_client.py", line 194, in upgrade_resource_types 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer gnocchi.resource_type.get (name = name) 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer 11:55:19.859 5401 ERROR ceilometer gnocchi.resource_type.get(name=name) 2017-11-10 11:55:19.859 5401 ERROR ceilometer File "/usr/lib/python2.7/dist-packages/gnocchiclient/v1/resource_type.py", line 44, in get 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer headers = {'Content-Type': "application / json"}). Json () 2017-11-10 11: 55: 19859 5401 ERROR ceilometer 11:55:19.859 5401 ERROR ceilometer headers={'Content-Type': "application/json"}).json() 2017-11-10 11:55:19.859 5401 ERROR ceilometer File "/usr/lib/python2.7/dist-packages/gnocchiclient/v1/base.py", line 37, in _get 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer 11:55:19.859 5401 ERROR ceilometer return self.client.api.get (* self.client.api.get(args, * *kwargs) 2017-11-10 11: 55: 19859 5401 ERROR ceilometer 11:55:19.859 5401 ERROR ceilometer File "/usr/lib/python2.7/dist-packages/keystoneauth1/adapter.py", line 288, in get 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer 11:55:19.859 5401 ERROR ceilometer return self.request (url, self.request(url, 'GET', * kwargs) 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer **kwargs) 2017-11-10 11:55:19.859 5401 ERROR ceilometer File "/usr/lib/python2.7/dist-packages/gnocchiclient/client.py", line 38, in request 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer 11:55:19.859 5401 ERROR ceilometer raise exceptions.from_response (resp, exceptions.from_response(resp, method) 2017-11-10 11: 55: 19.859 11:55:19.859 5401 ERROR ceilometer Forbidden: 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer <html> <head> 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer <title> 403 Forbidden 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer <body> 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer

Forbidden 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer

11:55:19.859 5401 ERROR ceilometer <html><head> 2017-11-10 11:55:19.859 5401 ERROR ceilometer <title>403 Forbidden</title> 2017-11-10 11:55:19.859 5401 ERROR ceilometer </head><body> 2017-11-10 11:55:19.859 5401 ERROR ceilometer Forbidden 2017-11-10 11:55:19.859 5401 ERROR ceilometer

You do not don't have permission to access / v1 / resource_type / ceph_account 2017-11-10 11: 55: 19.859 /v1/resource_type/ceph_account 2017-11-10 11:55:19.859 5401 ERROR ceilometer on this server. server.
2017-11-10 11: 55: 19.859 5401 ERROR ceilometer 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer

11:55:19.859 5401 ERROR ceilometer

2017-11-10 11:55:19.859 5401 ERROR ceilometer

2017-11-10 11: 55: 19.859 11:55:19.859 5401 ERROR ceilometer
Apache / 2.4.18 Apache/2.4.18 (Ubuntu) Server at controller Port 8041 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer 2017-11-10 11: 55: 19.859 5401 ERROR ceilometer 8041
2017-11-10 11:55:19.859 5401 ERROR ceilometer </body></html> 2017-11-10 11:55:19.859 5401 ERROR ceilometer (HTTP 403) 2017-11-10 11: 55: 19.859 11:55:19.859 5401 ERROR ceilometer

I do not know what the problem may be ... :-(

I do not know if it is necessary to add gnocchi with admin role and service project

Regards,

Hello again, I have been doing some checks and today I found that they have updated on yesterday 09/11/2017 the openstack guide for ubuntu 16.04 and the pike version in which they include how to install and configure gnocchi .

https://docs.openstack.org/ceilometer...

Anyway I realized that the user created gnocchi trying to add to the service project and role of admin I came to jump the errors of ceilometer-upgrade, all this with previous execution of both gnocchi-api and gnocchi-metricd. It is possible that the error I give you at http://paste.openstack.org/show/625930/ may come around but it depends on the configuration you have in gnocchi and ceilometer.


I have tried to install again ceilometer and gnocchi with the new openstack changes regarding the official guide.

https://docs.openstack.org/ceilometer/pike/install/install-base-ubuntu.html

I have managed to carry out all the steps, but there are some things that I have had to do in at least some. I still have some problem to solve.

"In the [storage] section, configure location to store metric data, in this case, we will store it to the local file system. See Gnocchi documentation for a list of more durable and performant drivers:"

[storage] coordination_url = redis: // controller: 6379 file_basepath = / var / lib / gnocchi driver = file

I was testing but at the time of executing the gnocchi-upgrade command I got connectivity errors with coordination_url.

It is necessary to install redis-server can be carried out with the command apt-get install redis-server without problem and have also installed the redis python module with pip install redis.

Then in /etc/redis/redis.conf I have changed the ip address set for the redis server (127.0.0.1) by the cloud management address of the controller.

I tried the gnocchi-upgrade command again and it did not return any errors.

Anyway, when I run the command "ceilometer-upgrade --skip-metering-database" it returns the following errors

WARNING oslo_reports.guru_meditation_report [-] Guru meditation now registers SIGUSR1 and SIGUSR2 by default for backward compatibility. SIGUSR1 will no longer be registered in a future release, so please use SIGUSR2 to generate reports. 2017-11-10 11:55:18.934 5401 INFO ceilometer.cmd.storage [-] Skipping metering database upgrade 2017-11-10 11:55:19.859 5401 CRITICAL ceilometer [-] Unhandled error: Forbidden: <html><head> <title>403 Forbidden</title> </head><body> Forbidden

You don't have permission to access /v1/resource_type/ceph_account on this server.


Apache/2.4.18 (Ubuntu) Server at controller Port 8041
</body></html> (HTTP 403) 2017-11-10 11:55:19.859 5401 ERROR ceilometer Traceback (most recent call last): 2017-11-10 11:55:19.859 5401 ERROR ceilometer File "/usr/bin/ceilometer-upgrade", line 10, in <module> 2017-11-10 11:55:19.859 5401 ERROR ceilometer sys.exit(upgrade()) 2017-11-10 11:55:19.859 5401 ERROR ceilometer File "/usr/lib/python2.7/dist-packages/ceilometer/cmd/storage.py", line 59, in upgrade 2017-11-10 11:55:19.859 5401 ERROR ceilometer gnocchi_client.upgrade_resource_types(conf) 2017-11-10 11:55:19.859 5401 ERROR ceilometer File "/usr/lib/python2.7/dist-packages/ceilometer/gnocchi_client.py", line 194, in upgrade_resource_types 2017-11-10 11:55:19.859 5401 ERROR ceilometer gnocchi.resource_type.get(name=name) 2017-11-10 11:55:19.859 5401 ERROR ceilometer File "/usr/lib/python2.7/dist-packages/gnocchiclient/v1/resource_type.py", line 44, in get 2017-11-10 11:55:19.859 5401 ERROR ceilometer headers={'Content-Type': "application/json"}).json() 2017-11-10 11:55:19.859 5401 ERROR ceilometer File "/usr/lib/python2.7/dist-packages/gnocchiclient/v1/base.py", line 37, in _get 2017-11-10 11:55:19.859 5401 ERROR ceilometer return self.client.api.get(args, *kwargs) 2017-11-10 11:55:19.859 5401 ERROR ceilometer File "/usr/lib/python2.7/dist-packages/keystoneauth1/adapter.py", line 288, in get 2017-11-10 11:55:19.859 5401 ERROR ceilometer return self.request(url, 'GET', **kwargs) 2017-11-10 11:55:19.859 5401 ERROR ceilometer File "/usr/lib/python2.7/dist-packages/gnocchiclient/client.py", line 38, in request 2017-11-10 11:55:19.859 5401 ERROR ceilometer raise exceptions.from_response(resp, method) 2017-11-10 11:55:19.859 5401 ERROR ceilometer Forbidden: 2017-11-10 11:55:19.859 5401 ERROR ceilometer <html><head> 2017-11-10 11:55:19.859 5401 ERROR ceilometer <title>403 Forbidden</title> 2017-11-10 11:55:19.859 5401 ERROR ceilometer </head><body> 2017-11-10 11:55:19.859 5401 ERROR ceilometer Forbidden 2017-11-10 11:55:19.859 5401 ERROR ceilometer

You don't have permission to access /v1/resource_type/ceph_account 2017-11-10 11:55:19.859 5401 ERROR ceilometer on this server.
2017-11-10 11:55:19.859 5401 ERROR ceilometer

2017-11-10 11:55:19.859 5401 ERROR ceilometer
2017-11-10 11:55:19.859 5401 ERROR ceilometer
Apache/2.4.18 (Ubuntu) Server at controller Port 8041
2017-11-10 11:55:19.859 5401 ERROR ceilometer </body></html> 2017-11-10 11:55:19.859 5401 ERROR ceilometer (HTTP 403) 2017-11-10 11:55:19.859 5401 ERROR ceilometer

I do not know what the problem may be ... :-(

I do not know if it is necessary to add gnocchi with admin role and service project

Regards,


Good afternoon,

Thank you very much for the answer, because the configuration of ceilometer I did it as it comes in the openstack guide of ubuntu in the pike version, which by the way I have seen that they have updated it with the steps to follow to install gnocchi.

  • Anyway I solved the errors following these recommendations.

https://stackoverflow.com/questions/45374863/devstackceilometergnocchi-error-403

<directory/> Options FollowSymLinks AllowOverride None <ifversion> = 2.4> Requires all granted <ifversion &lt;2.4=""> Order allow, deny Allow from all

I added this to /etc/apache2/sites-available/gnocchi-api.conf

Then I went back to execute the command "ceilometer-upgrade --skip-metering-database".

And I returned to give an error as that the service was not available, and I returned to carry out a step that does not appear in the documentation (although they have updated it).

It is to add the user gnocchi to the project "service" and with the role of "admin".

openstack role add --project service --user gnocchi admin

Then if I could execute the gnocchi metric list command and the metrics I had enabled appeared, but what I find curious is that in the Admin Dashboard the metrics do not appear anywhere or in a new tab or panel with the name " use of resources "as in previous versions.

How is that panel enabled or what needs to be done to show the statistics or the resources used in graphic form?

Regards,