Ask Your Question

Revision history [back]

Hi,

I have same problem and solve after removing inactive host from the database. Try what @Daniel suggest and if doesn't fix it please try the following method: 1. Verify if you have 2 or 1 compute node? 2. If you have 2 compute node please check that 2 node are alive/valid. 3. If you only have valid 1 compute node please remove the invalid host through mysql:

> use nova;
> select * from compute_nodes;

Look carefully and find the invalid hypervisor hostname.

> DELETE FROM compute_nodes where hypervisor_hostname='compute-node-name′;

Then remove host mapping on nova_api database:

> use nova_api;
> select * from host_mappings;
> DELETE FROM host_mappings WHERE host='compute-node-name';

And after that please try to run nova-status check upgrade, if it doesn't fix the problem please ensure that os_region_name match with your region settings in both controller and compute node. HTH

Hi,

I have same problem and solve after removing inactive host from the database. Try what @Daniel suggest and if doesn't fix it please try the following method: 1. method:

  1. Verify if you have 2 or 1 compute node? 2. node?
  2. If you have 2 compute node please check that 2 node are alive/valid. 3. alive/valid.
  3. If you only have valid 1 compute node please remove the invalid host through mysql:

Login to mysql and start finding.

> mysql -u root -pyour-password
> use nova;
> select * from compute_nodes;

Look carefully and find the invalid hypervisor hostname.

> DELETE FROM compute_nodes where hypervisor_hostname='compute-node-name′;

Then remove host mapping on nova_api database:

> use nova_api;
> select * from host_mappings;
> DELETE FROM host_mappings WHERE host='compute-node-name';

And after that please try to run nova-status check upgrade, if it doesn't fix the problem please ensure that os_region_name match with your region settings in both controller and compute node. HTH