Ask Your Question

Revision history [back]


Issue about node not reachable is:

neutron_external_interface is used for br-ex, this interface will be managed by openvswitch, this causes that when assigning this interface to br-ex, all config/connections in the interface will be dropped.

Access to the server should be done by any other interface.

I would recommend use api interface as management network.

To simplify interface config when tunnel/api is in the same interface, use network_interface=<value> for each node. Internally api_interface and tunnel_interface uses network_interface if not defined.

In you inventory example:

anscontroller network_interface=enp0s3 neutron_external_interface=enp0s8

anscontroller network_interface=enp0s3 neutron_external_interface=enp0s8

# skylake1
mgwlab7 network_interface=eno1 #Compute does not need neutron_external_interface unless using DVR or provider networks

neutron_external_interface is defined with different values in inventory and globals. Make sure for using enp0s8 set properly value. You globals:

kolla_internal_vip_address: ""
network_interface: "enp0s8" # Remove this, will override values in inventory.
neutron_external_interface: "enp0s3" #If all nodes use the same value, can also remove fro inventory.
neutron_plugin_agent: "openvswitch" # This can be removed, is default value

Values in globals.yml override every other variable, this means that setting network_interface=eth1 will override value for compute where in inventory set network_interface=eth2, causing issues.

If all nodes share same interface configuration, use globals.yml for all nodes, if not, set interface in inventory.