Ask Your Question

Revision history [back]

Hi, Docker systemd files need proxy settings.

Please check, https://docs.docker.com/engine/admin/systemd/#httphttps-proxy

As sort resume for kolla-ansible, assume your systemd service is /etc/systemd/system/docker.service.d/kolla.conf:

[Service]
Environment="HTTP_PROXY=http://proxy.example.com:80/"
ExecStart=
ExecStart=/usr/bin/dockerd --insecure-registry 192.168.100.1:4000
MountFlags=shared

Then reload systemd daemons and restart docker.

systemctl daemon-reload
systemctl restart docker

Regards