Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Hi Praveen,

I have tried to restart the service. However, still having the same error. I use Cirros which is recommended in the openstack installation link.

[root@controller ~]# openstack flavor list
+--------------------------------------+---------+------+------+-----------+-------+-----------+
| ID                                   | Name    |  RAM | Disk | Ephemeral | VCPUs | Is Public |
+--------------------------------------+---------+------+------+-----------+-------+-----------+
| 7fe4a706-039a-44a2-8366-b64cf3339ec2 | m1.nano |  64  |   2  |         0 |     1 | True      |
+--------------------------------------+---------+------+------+-----------+-------+-----------+
[root@controller ~]# openstack image list
+--------------------------------------+--------+--------+
| ID                                   | Name   | Status |
+--------------------------------------+--------+--------+
| 5d59dc57-3580-47f6-bb77-171d76b59fff | cirros | active |
+--------------------------------------+--------+--------+

Hi eblock,

I have checked the [placement] in the nova.conf and configuration is as below.

[placement]
os_region_name = RegionOne
project_domain_name = Default
project_name = service
auth_type = password
user_domain_name = Default
auth_url = http://controller:35357/v3
username = placement
password = Password123

Below is the service-list from nova

+----+------------------+------------+----------+---------+-------+-------------    
| Id | Binary           | Host       | Zone     | Status  | State | Updated_at    
+----+------------------+------------+----------+---------+-------+-------------    
| 1  | nova-scheduler   | controller | internal | enabled | up    | 2017-07-12T1    
| 2  | nova-conductor   | controller | internal | enabled | up    | 2017-07-12T1    
| 3  | nova-consoleauth | controller | internal | enabled | up    | 2017-07-12T1    
| 8  | nova-compute     | compute1   | nova     | enabled | up    | 2017-07-12T1    
+----+------------------+------------+----------+---------+-------+-------------

Hi Bernd,

I have checked the port 9292, it has enabled on the firewalld side.

[root@controller ~]#   firewall-cmd --list-all
public (active)
  target: default
  icmp-block-inversion: no
  interfaces: ens160 ens192
  sources:
  services: dhcpv6-client ssh
  ports: 9292/tcp 3389/tcp 5672/tcp 80/tcp 35357/tcp
  protocols:
  masquerade: no
  forward-ports:
  sourceports:
  icmp-blocks:
  rich rules:
[root@controller ~]#

I tried to check through all the installation verification steps and found below warning message:

root@controller ~]# nova-status upgrade check
+-------------------------------------------------------------------+
| Upgrade Check Results                                             |
+-------------------------------------------------------------------+
| Check: Cells v2                                                   |
| Result: Success                                                   |
| Details: None                                                     |
+-------------------------------------------------------------------+
| Check: Placement API                                              |
| Result: Success                                                   |
| Details: None                                                     |
+-------------------------------------------------------------------+
| Check: Resource Providers                                         |
| Result: Warning                                                   |
| Details: There are no compute resource providers in the Placement |
|   service but there are 1 compute nodes in the deployment.        |
|   This means no compute nodes are reporting into the              |
|   Placement service and need to be upgraded and/or fixed.         |
|   See                                                             |
|   http://docs.openstack.org/developer/nova/placement.html         |
|   for more details.                                               |
+-------------------------------------------------------------------+

Seems the resource providers having warning message. Is this normal ?

Please advise and thank you very much in advance.