Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Yes , I am . Some of snapshots worked and really fast . But after 3 or 4 snapshot it got really slow again . So I start to investigating all components and what I did was : 1- Include the following configuration ( what I don't think that was the cause of the fix )

hw_disk_discard = unmap 
live_migration_flag = "VIR_MIGRATE_UNDEFINE_SOURCE,VIR_MIGRATE_PEER2PEER,VIR_MIGRATE_LIVE,VIR_MIGRATE_PERSIST_DEST,VIR_MIGRATE_TUNNELLED" 
images_rbd_ceph_conf = /etc/ceph/ceph.conf

2- Include at [client] section of /etc/ceph/ceph.conf file with the follow statement in all compute node :

 admin socket = /var/run/ceph/guests/$cluster-$type.$id.$pid.$cctid.asok
 log file = /var/log/qemu/qemu-guest-$pid.log
 rbd concurrent management ops = 20

There was also another important fix that I supposed that helped in the solution as fix some unclean pg in my ceph cluster . I do not know why it interfere at the fix because the unclean pgs was in another pool that was not related to the vms or images pools .

Now I am doing some testing with 80 GB vms in QCOW format .

Yes , I am . Some of times snapshots worked and works really fast . But Although after 3 or 4 snapshot it got really slow again . So I start started to investigating all components and what I did was : 1- Include the following configuration ( what I don't think that was the cause of the fix )

hw_disk_discard = unmap 
live_migration_flag = "VIR_MIGRATE_UNDEFINE_SOURCE,VIR_MIGRATE_PEER2PEER,VIR_MIGRATE_LIVE,VIR_MIGRATE_PERSIST_DEST,VIR_MIGRATE_TUNNELLED" 
images_rbd_ceph_conf = /etc/ceph/ceph.conf

2- Include at [client] section of /etc/ceph/ceph.conf file with the follow statement in all compute node :

 admin socket = /var/run/ceph/guests/$cluster-$type.$id.$pid.$cctid.asok
 log file = /var/log/qemu/qemu-guest-$pid.log
 rbd concurrent management ops = 20

There was also another important fix that I supposed that helped in the solution as fix some unclean pg in my ceph cluster . I do not know why it interfere at the fix because the unclean pgs was in another pool that was not related to the vms or images pools .

Now I am doing some testing with 80 GB vms in QCOW format . .

Some times snapshots works really fast . Although after 3 or 4 snapshot it got really slow again . So I started to investigating all components and what I did was : 1- Include the following configuration ( what I don't think that was the cause of the fix )

hw_disk_discard = unmap 
live_migration_flag = "VIR_MIGRATE_UNDEFINE_SOURCE,VIR_MIGRATE_PEER2PEER,VIR_MIGRATE_LIVE,VIR_MIGRATE_PERSIST_DEST,VIR_MIGRATE_TUNNELLED" 
images_rbd_ceph_conf = /etc/ceph/ceph.conf

2- Include at [client] section of /etc/ceph/ceph.conf file with the follow statement in all compute node :

 admin socket = /var/run/ceph/guests/$cluster-$type.$id.$pid.$cctid.asok
 log file = /var/log/qemu/qemu-guest-$pid.log
 rbd concurrent management ops = 20

There was also another important fix that I supposed that helped in the solution as fix some unclean pg in my ceph cluster . I do not know why it interfere at the fix because the unclean pgs was in another pool that was not related to the vms or images pools .

Now I am doing After some testing test with 80 GB vms in QCOW format instance the image stuck at saving state . Investigating .