Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

You need to upgrade the package keystoneauth1, because the version that you have in your system is: 2.4.3 And Glance needs version: >=2.16.0.

Try the following:

pip install 'keystoneauth1>=2.16.0'

But I think you will have more error like that in the future.

I hava had the same with Devstack, after rebuild it multiple times, The only solution was to reinstall my enviroment and start again, but maybe you have more luck than me.

You need to upgrade the package keystoneauth1, because the version that you have in your system is: 2.4.3 And Glance needs version: >=2.16.0.

Try the following:

pip install 'keystoneauth1>=2.16.0'

But I think you will have more error like that in the future.

I hava have had the same erros with Devstack, after rebuild it multiple times, The only solution was to reinstall my enviroment and start again, but maybe you have more luck than me.