Revision history [back]

Option "notification_driver" from group "DEFAULT" is deprecated. Use option "driver" from group "oslo_messaging_notifications".
Could not load neutron.openstack.common.notifier.rpc_notifier

So it would seem that your notification_driver option in neutron.conf is set to neutron.openstack.common.notifier.rpc_notifier. My Ocata installation, which I created by following the Centos installation tutorial, doesn't set the driver at all, so that Neutron uses the default. Also, I don't have /lib/python2.7/site-packages/neutron/openstack/common on my system; I do have /lib/python2.7/site-packages/neutron/notifiers. And I don't have rpc_notifier anywhere in my code.

All this points to a misconfiguration in neutron.conf, but perhaps your setup is too different from mine to comment on that. My suggestion: Remove the notification_driver setting from neutron.conf.