Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

All files have the correct dns entry.

My VM's /etc/resolve.conf file has this entry:

$ cat /etc/resolv.conf 
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN    
nameserver 8.8.4.4
nameserver 8.8.8.8
search openstacklocal

The local tenant network configuration is the next:

Name                    subnet0
ID                      7d8f026d-fa45-4c20-9af4-b1bb38d4825b 
Network Name            net0
Network ID              56ebd398-d910-4c22-b844-87406ea4f40a
Subnet Pool             None
IP Version              IPv4
CIDR                    10.10.0.0/24
IP Allocation Pools     Start 10.10.0.2 - End 10.10.0.254
Gateway IP              10.10.0.1
DHCP Enabled            Yes
Additional Routes       None 
DNS Name Servers        8.8.4.4 8.8.8.8

I think that my problem is neutron service devstack@q-dhcp.service, which starts 'dnsmasq' with these options:

dnsmasq --no-hosts --no-resolv --strict-order --except-interface=lo --pid-file=/opt/stack/data/neutron/dhcp/56ebd398-d910-4c22-b844-87406ea4f40a/pid --dhcp-hostsfile=...

And I don't know how to modify it.

Thanks for your answer, Vinoth