Ask Your Question

Revision history [back]

*hi all

i also have the similar error but i dont have the requires: python-tinyrpc

2017-02-22 00:31:50::ERROR::run_setup::1018::root:: Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/packstack/installer/", line 1013, in main
    _main(options, confFile, logFile)
  File "/usr/lib/python2.7/site-packages/packstack/installer/", line 660, in _main
  File "/usr/lib/python2.7/site-packages/packstack/installer/", line 627, in runSequences
  File "/usr/lib/python2.7/site-packages/packstack/installer/", line 81, in runAllSequences, messages=self.MESSAGES)
  File "/usr/lib/python2.7/site-packages/packstack/installer/core/", line 109, in run, messages=messages)
  File "/usr/lib/python2.7/site-packages/packstack/installer/core/", line 50, in run
    self.function(config, messages)
  File "/usr/lib/python2.7/site-packages/packstack/plugins/", line 214, in apply_puppet_manifest
    wait_for_puppet(currently_running, messages)
  File "/usr/lib/python2.7/site-packages/packstack/plugins/", line 128, in wait_for_puppet
  File "/usr/lib/python2.7/site-packages/packstack/modules/", line 107, in validate_logfile
    raise PuppetError(message)
PuppetError: Error appeared during Puppet run:
Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install openstack-neutron' returned 1: Error: Package: python2-ryu-4.9-2.el7.noarch (openstack-newton)
You will find full trace in log /var/tmp/packstack/20170221-235024-LxFxK3/manifests/

i tried the workaround of jpena-c but when i try to install the rpm file is missing dependencies*

[root@cloud tech5]#  rpm -iv python2-tinyrpc-0.5-2.el7.noarch.rpm
error: Failed dependencies:
        python-gevent is needed by python2-tinyrpc-0.5-2.el7.noarch
        python-zmq is needed by python2-tinyrpc-0.5-2.el7.noarch

i tried to install the firt python-gevent dependences and that was the output:

[root@cloud tech5]# rpm -iv python2-tinyrpc-0.5-2.el7.noarch.rpm python2-gevent-1.1.2-2.el7.x86_64.rpm
error: Failed dependencies:
        python-zmq is needed by python2-tinyrpc-0.5-2.el7.noarch is needed by python2-gevent-1.1.2-2.el7.x86_64 is needed by python2-gevent-1.1.2-2.el7.x86_64

thanks for your answers.