Ask Your Question

Revision history [back]

What I did:

  1. Copied the default wsgi file to a new one:

    sudo cp /usr/lib/python2.7/dist-packages/ceilometer/api/app.wsgi /var/www/cgi-bin/ceilometer/app/app.wsgi

  2. Changed the WSGIScriptAlias line in /etc/apache2/sites-available/ceilometer.conf

    WSGIScriptAlias / "/var/www/cgi-bin/ceilometer/app/app.wsgi"

Side note: it seems 'ceilometer-api' component is not needed (even though the guide asks us to install it). If you check the ceilometer-api logs it's trying to enable a its service on port 8777, which Apache already enabled. Anyway, Ceilometer API through port 8777 is deprecated in favor of Gnocchi and other components

What I did:

  1. Copied the default wsgi file to a new one:

    sudo cp /usr/lib/python2.7/dist-packages/ceilometer/api/app.wsgi /var/www/cgi-bin/ceilometer/app/app.wsgi

  2. Changed the WSGIScriptAlias line in /etc/apache2/sites-available/ceilometer.conf

    WSGIScriptAlias / "/var/www/cgi-bin/ceilometer/app/app.wsgi"

Side note: it seems 'ceilometer-api' component is not needed (even though the guide asks us to install it). If you check the ceilometer-api logs it's trying to enable a its service on port 8777, which Apache already enabled. Anyway, Ceilometer API through port 8777 is deprecated in favor of Gnocchi and other components

Had the same problem. What I did:did to make it work:

  1. Copied the default wsgi file to a new one:

    sudo cp /usr/lib/python2.7/dist-packages/ceilometer/api/app.wsgi /var/www/cgi-bin/ceilometer/app/app.wsgi

  2. Changed the WSGIScriptAlias line in /etc/apache2/sites-available/ceilometer.conf

    WSGIScriptAlias / "/var/www/cgi-bin/ceilometer/app/app.wsgi"

Side note: it seems 'ceilometer-api' component is not needed (even though the guide asks us to install it). If you check the ceilometer-api logs it's trying to enable its service on port 8777, which Apache already enabled. Anyway, Ceilometer API through port 8777 is deprecated in favor of Gnocchi and other components