Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

I investigated further.

2016-12-14 09:22:36.437293 path = os.path.join(os.path.dirname(upath(p.__file__)), 'locale') 2016-12-14 09:22:36.437296 AttributeError: 'module' object has no attribute '__file__'

Is this related to lack of locale files under the following directories? /opt/stack/horizon/horizon/local /opt/stack/horizon/openstack_dashboard/locale

Let me know if i am in the right direction.

I investigated further.

2016-12-14 09:22:36.437293 path = os.path.join(os.path.dirname(upath(p.__file__)), 'locale') 2016-12-14 09:22:36.437296 AttributeError: 'module' object has no attribute '__file__'

Is this related to lack of locale files under the following directories? /opt/stack/horizon/horizon/local directories?

/opt/stack/horizon/horizon/local

/opt/stack/horizon/openstack_dashboard/locale

Let me know if i am in the right direction.

I investigated further.

2016-12-14 09:22:36.437293 path = os.path.join(os.path.dirname(upath(p.__file__)), 'locale') 2016-12-14 09:22:36.437296 AttributeError: 'module' object has no attribute '__file__'

Is this related to lack of locale files under further by comparing the logs with a working installation.

it seems that the following directories?

/opt/stack/horizon/horizon/local

/opt/stack/horizon/openstack_dashboard/locale

Let folders/files are not generated in my case: /opt/stack/tacker-horizon/tacker_horizon/locale /opt/stack/tacker-horizon/tacker_horizon/__init__.pyc /opt/stack/tacker-horizon/tacker_horizon/openstack_dashboard/dashboards/nfv/__init__.pyc /opt/stack/tacker-horizon/tacker_horizon/openstack_dashboard/dashboards/nfv/locale

My local.conf reads as follows:


[[local|localrc]] HOST_IP=127.0.0.1

ADMIN_PASSWORD=devstack MYSQL_PASSWORD=devstack

RABBIT_PASSWORD=devstack

SERVICE_PASSWORD=$ADMIN_PASSWORD

SERVICE_TOKEN=devstack

PIP_USE_MIRRORS=False

USE_GET_PIP=1

OFFLINE=True

LOGFILE=$DEST/logs/stack.sh.log

SCREEN_LOGDIR=$DEST/logs/screen

VERBOSE=True

ENABLE_DEBUG_LOG_LEVEL=True

ENABLE_VERBOSE_LOG_LEVEL=True

Q_PLUGIN=ml2

Q_AGENT=openvswitch

Q_USE_PROVIDERNET_FOR_PUBLIC=False

FLOATING_RANGE=10.10.10.0/24

Q_FLOATING_ALLOCATION_POOL="start=10.10.10.101,end=10.10.10.201"

PUBLIC_NETWORK_NAME=external

PUBLIC_NETWORK_GATEWAY=10.10.10.1

PUBLIC_PHYSICAL_NETWORK=public

PUBLIC_BRIDGE=br-ext

NETWORK_GATEWAY=${NETWORK_GATEWAY:-15.0.0.1}

FIXED_RANGE=${FIXED_RANGE:-15.0.0.0/24}

enable_plugin tacker https://git.openstack.org/openstack/tacker

enable_plugin networking-sfc git://git.openstack.org/openstack/networking-sfc stable/newton

enable_service n-novnc

enable_service n-cauth

disable_service tempest


Please let me know if i am in the right direction.

there is anything wrong.