Ask Your Question

Revision history [back]

I had the same issue. Here is a couple of things to check:

1- Double Check the ceilometer configuration: /etc/ceilometer/ceilometer.conf

[keystone_authtoken] auth_host = controller auth_port = 35357
auth_protocol = http auth_uri = http://controller:5000
admin_tenant_name = service
admin_user = ceilometer
admin_password = CEILOMETER_PASS

[service_credentials]
os_auth_url = http://controller:5000/v2.0
os_username = ceilometer
os_tenant_name = service
os_password = CEILOMETER_PASS

2- Use the logs to investigate the errors:

  • /var/log/keystone/keystone-all.log
  • /var/log/ceilometer/ceilometer-api.log

3- Check mongodb password, reset if needed

4- Check Ceilometer services:

export CEILO_SVCS='agent-central agent-notification ceilometer-api ceilometer-collector alarm-evaluator alarm-notifier' for svc in $CEILO_SVCS ; do sudo service ceilometer-$svc restart ; done

5- Check if the service and the endpoints (admin, internal and public) are correctly configured

6- [This solved my issue] Check the user ceilometer password, if needed delete and recreate the user and assign the appropriate role and roject, this solved my issue.

(Careful!! It was in a lab environment during first deployment, I guess it would be eventual consequences for your alarms created with the old user!! )